XAMPP Performance Increase x3 on XP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Performance Increase x3 on XP

Postby ianarmstrong » 18. October 2007 01:43

My XAMPP installation underwent a dramatice performance increase of three times several days ago - the reason for which I do not know. I have had to reboot since then and now I cannot get apache/mysql to perform the way it was- it is quite slow.

So the point is that I was doing a few standard bits and piecves on the machine and then BANG! when I went back to my PHP project the servers were responding 3 times faster. I have rebooted and its back to the normal slow speed.

Obviously I havn't done any hardware or software updates. I had killed explorer.exe and restarted it, however, I have tried to emulate that and apache/mysql are still run as slow as normal.

I would have tollerated this as it is only for development, but since getting a three fold increase without reconfiguring anything, I am very keen to get it back again!

I can only think there is an service running somewhere or an option switched on that is slowing things down dramtically. The machine itself is fast and not over burdened.

If anyone knows about apache/mysql performance issues on XP a point in the right direction would be helpful.

Posts: 2
Joined: 18. October 2007 01:33

Postby ldivinag » 20. October 2007 09:35

one thing:

mysql's big selling point is that it caches the result set very well.

i could remember back a few years ago, when version 4 of mysql came out it with it.

a popular IT weekly magazine (infoworld) ran a shoot out between mysql, oracle, sybase... all the big (expensive) DBMS.

mysql and oracle were nearly tied in first place. it was the caching that made this possible.

when you rebooted, the cache was or maybe flushed and you had to restart...

just a thought??????
leo d.
User avatar
Posts: 40
Joined: 19. April 2006 04:18


Postby ianarmstrong » 22. October 2007 22:07

Thanks for your reply. I tracked it to the viruse scanner running on my machine. Took it off and the performance sky rocketed. I've put a different scanner on - which _is_ monitoring web pages and the performance is still great. Obvious now that I think of it but didn;t at the time.
Posts: 2
Joined: 18. October 2007 01:33

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests