problem with XAMPP and CartWeaver 3

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problem with XAMPP and CartWeaver 3

Postby jonathandenwood » 17. October 2007 00:07

Hi Folks I am having some troubles getting XAMPP to work with Cartweaver3
I make a new user in MySQL and give it a password no problem setup Cartweaver give it the username and password let it make a new database as normal then I go to the normal index page and view it I get this warning message


Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\cw_test\cw3\CWLibrary\CWDBMySQL.php on line 123

Fatal error: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\cw_test\cw3\CWLibrary\CWDBMySQL.php on line 123

I am a bit confused on what the problem is can you give me some advice on this? If you like I can post the code from the CWDBMySql.php if needed.

Take care

Jonathan
jonathandenwood
 
Posts: 3
Joined: 16. October 2007 21:56

Postby Wiedmann » 17. October 2007 00:20

Code: Select all
Fatal error: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\cw_test\cw3\CWLibrary\CWDBMySQL.php on line 123

I am a bit confused on what the problem is can you give me some advice on this?

This script is not using a configured username/password.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby adamjw3 » 17. October 2007 01:00

i'm no expert but it sounds like you have put the wrong settings in your database config file or database connection which ever one you have used.

have you tried it with a blank password?
adamjw3
 
Posts: 7
Joined: 16. October 2007 22:29

Postby jonathandenwood » 17. October 2007 01:26

Hi adamjw3 thanks for the reply I think I tried that with no success. However I give it a go this evening.

Take care

Jonathan
jonathandenwood
 
Posts: 3
Joined: 16. October 2007 21:56

Postby jonathandenwood » 17. October 2007 04:32

Hi Wiedmann, thanks for your reply. Can you give me some more details about your remark that "This script is not using a configured username/password." I don't really understand this remark.

Take care

Jonathan
jonathandenwood
 
Posts: 3
Joined: 16. October 2007 21:56

Postby Wiedmann » 17. October 2007 15:05

This script is not using a configured username/password."

Well,
jonathandenwood wrote:setup Cartweaver give it the username and password

Here you told us, that you have configured a MySQL username in "Cartweaver".

jonathandenwood wrote:Fatal error: Access denied for user 'ODBC'@'localhost' (using password: NO) in C:\Program Files\xampp\htdocs\cw_test\cw3\CWLibrary\CWDBMySQL.php on line 123

But this "Cartweaver" script ("CWDBMySQL.php") don't use the configured username. (a mysql_connect without using a username results in the username "ODBC'@'localhost").
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests