Apache Stopped

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Stopped

Postby ike » 15. October 2007 12:49

Hi there,
I am using Xampp version 2.5. I am using the Apache and MySQL service and it was working perfectly when i installed it. After a couple of days the Apache service has stopped but MySQL is running. I have tried starting it manually and even restarting the PC several times but all to no avail. It is still not responding.
Due to this i am not able to run my web server software.
Please help.

Isaac
ike
 
Posts: 4
Joined: 15. October 2007 12:38
Location: Ghana

Postby Wiedmann » 15. October 2007 13:05

Read the Windows application eventlog.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ike » 15. October 2007 17:06

This is the error i am getting in windows event viewer.

The Apache service named reported the following error:
>>> apache.exe: Syntax error on line 526 of C:/Program Files/xampp/apache/conf/httpd.conf: Could not open configuration file C:/Program Files/xampp/apache/conf/extra/ocsinventory.conf: The system cannot find the file specified. .

please help.
ike
 
Posts: 4
Joined: 15. October 2007 12:38
Location: Ghana

Postby Wiedmann » 15. October 2007 17:12

Well, you have more questions?
--> Just correct the include directive in the "httpd.conf", line 526.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ike » 15. October 2007 18:48

I have checked the path. I un-installed the xampp and re-installed it again.
I am now getting this error in application event viewer.

The Apache service named reported the following error:
>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

I don't even understand the error i am getting.
what do i do to get Apache running on xampp.

Thanks,
Isaac
ike
 
Posts: 4
Joined: 15. October 2007 12:38
Location: Ghana

Postby Wiedmann » 15. October 2007 21:59

>>> (OS 10048)Only one usage of each socket address (protocol/network address/port) is normally permitted. : make_sock: could not bind to address 0.0.0.0:80

I don't even understand the error i am getting.

There is allready a webserver running. You can't start a second one.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby ike » 16. October 2007 11:55

I have never configured a web server on my pc's. How do i know a web server is running on my pc. And how do i stop it so that xampp apache can run without any errors.
I am desperate to use xampp in running a web server software called h-inventory.

thanks
ike
 
Posts: 4
Joined: 15. October 2007 12:38
Location: Ghana

Postby Wiedmann » 16. October 2007 13:44

How do i know a web server is running on my pc.

For example with netstat or xampp-portcheck.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 45 guests