Software crashes after running XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Software crashes after running XAMPP

Postby drewbocz » 12. October 2007 00:40

Hi, I'm using Win XP SP2 running XAMPP 1.6.4 (but this problem happened when I was still running 1.6.3).

XAMPP ran smoothly for sometime after initial installation. However, just recently, I've been experiencing this. Whenever I start Apache and mySQL, ANY software that I run after that crashes. Even my windows task manager crashes.

It doesn't matter if I stop Apache and mySQL. Doesn't matter if I exit XAMPP or kill off their process in task manager. Once I start them, any software that I run after that event is bound to crash.

Anyone with a similar experience? Anyone with a solution?

Thanks.
drewbocz
 
Posts: 2
Joined: 12. October 2007 00:31
Location: Philippines

Postby Izzy » 12. October 2007 01:23

What messages are in the Windows Event viewer after the crashes?

Any indications in the Apache error logs?


===========================================
Take a look at the new DeskTopXampp launch control for XAMPP
and XAMPPlite (DTX.exe) posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967
Available at Ridgewood's new DTX web site http://zedfiles.com/DTX/
Also available here: http://nat32.com/dtx/
I highly recommend DTX.
============================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby drewbocz » 12. October 2007 07:39

Ok, this time, I just started Apache (without mySQL), then opened MS-Word.
I got a MS-Word popup saying "MS-Word has encountered a problem and needs to close. We are sorry for the inconvenience..." then the Dr. Watson Postmortem Debugger pops out with the same message: "Dr. Watson Postmortem Debugger has encountered a problem and needs to close..."

In fact anything I open comes out with that message. Any software that IS ALREADY open when I start Apache though, seems to be unaffected.

These are the Apache error log contents for that session:

[Fri Oct 12 14:27:37 2007] [notice] Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4 configured -- resuming normal operations
[Fri Oct 12 14:27:37 2007] [notice] Server built: Sep 21 2007 00:29:38
[Fri Oct 12 14:27:37 2007] [notice] Parent: Created child process 2384
[Fri Oct 12 14:27:39 2007] [notice] Child 2384: Child process is running
[Fri Oct 12 14:27:39 2007] [notice] Child 2384: Acquired the start mutex.
[Fri Oct 12 14:27:39 2007] [notice] Child 2384: Starting 250 worker threads.
[Fri Oct 12 14:27:39 2007] [notice] Child 2384: Starting thread to listen on port 443.
[Fri Oct 12 14:27:39 2007] [notice] Child 2384: Starting thread to listen on port 80.

The Windows event viewer logs errors like these:

Faulting application dw20.exe, version 11.0.6560.0, faulting module , version 0.0.0.0, fault address 0x00000000.

Faulting application winword.exe, version 11.0.8134.0, stamp 461557b7, faulting module kernel32.dll, version 5.1.2600.3119, stamp 46239f3f, debug? 0, fault address 0x00083f9c.

Faulting application drwtsn32.exe, version 5.1.2600.0, faulting module kernel32.dll, version 5.1.2600.3119, fault address 0x00083f9c.


Appreciate the help :)
drewbocz
 
Posts: 2
Joined: 12. October 2007 00:31
Location: Philippines


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests