libapr.dll error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

libapr.dll error

Postby Gun-Nut » 10. October 2007 13:37

Every time I start up Apache I get the error message.

the procedure entry point _apr_socket_create@16 could not be located in the dynamic link library libapr.dll

How may I fix this?
Gun-Nut
 
Posts: 2
Joined: 04. November 2006 22:38

Postby LEW21 » 22. October 2007 20:42

I have the same problem, does anybody know a solution?
LEW21
 
Posts: 1
Joined: 22. October 2007 20:40

Postby hfrmobile » 27. October 2007 11:07

Having a similar problem with libapr.dll ...

Using Subversion and when I try to commit to SVN database then following problem occurs:

http://community.apachefriends.org/f/viewtopic.php?t=27025&highlight=libapr


procedure entry point sounds like a version problem between some DLLs...
hfrmobile
 
Posts: 12
Joined: 18. August 2007 11:07
Location: Austria

Postby dgmcbsolutions » 11. November 2007 18:16

Hi,
I ran the upgrade installer to upgrade to Xampp for windows 1.6.4.

All seems ok, just this same error when starting apache. Apache still loads for me, and since this is on my local windows machine used for development only, its no big deal.

I would like to get rid of that error message however. I'm running windows xp sp2.

Did anyone have a solution to this? I'm no apache expert. Thanks for any help!
dgmcbsolutions
 
Posts: 1
Joined: 11. November 2007 17:58

Postby hfrmobile » 12. November 2007 10:22

dgmcbsolutions wrote:I would like to get rid of that error message however. I'm running windows xp sp2.

Did anyone have a solution to this? I'm no apache expert. Thanks for any help!


Somewhere I read that Apache 2.2 / WebDAV will not run with Windows. Since the current version of XAMPP comes with Apache 2.2 I decided to forget XAMPP distribution and now I am using Apache 2.0 directly (without the XAMPP stuff) and now it works with SVN!

There exists also an MSI package for Apache 2.0 and so it is easy to install. Of course you have to configure httpd.conf but this also must be done if using XAMPP.
hfrmobile
 
Posts: 12
Joined: 18. August 2007 11:07
Location: Austria


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests