Error 403 Forbidden

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error 403 Forbidden

Postby VampInc » 07. October 2007 10:11

Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403
localhost
10/07/07 05:05:35
Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3

I just installed XAMPP maybe 16 hours or so ago. Everything checks out fine, until I goto view my site. I can not view from localhost, 127.0.0.1 or my url.

I do have a couple other sites on my server so I have had to edit my vhost file. Which is a little different from the setup I was running before I installed this package. But I can't seem to 1.) get past the forbidden issue and 2.) set my vhost correctly. My error log shows the dir does not exist.

[Sun Oct 07 04:54:24 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3 configured -- resuming normal operations
[Sun Oct 07 04:54:24 2007] [notice] Server built: Mar 5 2007 11:23:00
[Sun Oct 07 04:54:24 2007] [notice] Parent: Created child process 3328
Warning: DocumentRoot [C:/xampp/celtic] does not exist
Warning: DocumentRoot [C:/xampp/wkb] does not exist
[Sun Oct 07 04:54:29 2007] [notice] Child 3328: Child process is running
[Sun Oct 07 04:54:29 2007] [notice] Child 3328: Acquired the start mutex.
[Sun Oct 07 04:54:29 2007] [notice] Child 3328: Starting 250 worker threads.
[Sun Oct 07 04:54:29 2007] [notice] Child 3328: Starting thread to listen on port 443.
[Sun Oct 07 04:54:29 2007] [notice] Child 3328: Starting thread to listen on port 80.
[Sun Oct 07 04:54:52 2007] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/
[Sun Oct 07 04:54:55 2007] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/indextest.php
[Sun Oct 07 05:05:35 2007] [error] [client 127.0.0.1] client denied by server configuration: C:/xampp/

Any clue as to what I am missing?

Thank you for your time.
VampInc
 
Posts: 3
Joined: 07. October 2007 10:01

Postby VampInc » 07. October 2007 10:50

Error log update:
[Sun Oct 07 05:41:31 2007] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Oct 07 05:41:31 2007] [notice] Child 1628: Exit event signaled. Child process is ending.
[Sun Oct 07 05:41:32 2007] [notice] Child 1628: Released the start mutex
[Sun Oct 07 05:41:33 2007] [notice] Child 1628: Waiting for 250 worker threads to exit.
[Sun Oct 07 05:41:33 2007] [notice] Child 1628: All worker threads have exited.
[Sun Oct 07 05:41:33 2007] [notice] Child 1628: Child process is exiting
[Sun Oct 07 05:41:33 2007] [notice] Parent: Child process exited successfully.
[Sun Oct 07 05:41:35 2007] [info] Init: Seeding PRNG with 136 bytes of entropy
[Sun Oct 07 05:41:36 2007] [info] Loading certificate & private key of SSL-aware server
[Sun Oct 07 05:41:36 2007] [debug] ssl_engine_pphrase.c(469): unencrypted RSA private key - pass phrase not required
[Sun Oct 07 05:41:36 2007] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Sun Oct 07 05:41:39 2007] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Sun Oct 07 05:41:39 2007] [debug] ssl_scache_dbm.c(409): Inter-Process Session Cache (DBM) Expiry: old: 0, new: 0, removed: 0
[Sun Oct 07 05:41:39 2007] [info] Init: Initializing (virtual) servers for SSL
[Sun Oct 07 05:41:39 2007] [info] Configuring server for SSL protocol
[Sun Oct 07 05:41:39 2007] [debug] ssl_engine_init.c(405): Creating new SSL context (protocols: SSLv2, SSLv3, TLSv1)
[Sun Oct 07 05:41:39 2007] [debug] ssl_engine_init.c(601): Configuring permitted SSL ciphers [ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL]
[Sun Oct 07 05:41:39 2007] [debug] ssl_engine_init.c(729): Configuring RSA server certificate
[Sun Oct 07 05:41:39 2007] [debug] ssl_engine_init.c(768): Configuring RSA server private key
[Sun Oct 07 05:41:39 2007] [info] Server: Apache/2.2.4, Interface: mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Sun Oct 07 05:41:39 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:39 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:39 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x592d10 rmm=0x592d38 for VHOST: localhost
[Sun Oct 07 05:41:39 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x592d10 rmm=0x592d38 for VHOST: local.wkb.myvnc.com
[Sun Oct 07 05:41:39 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x592d10 rmm=0x592d38 for VHOST: local.celticmemory.bounceme.net
[Sun Oct 07 05:41:39 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x592d10 rmm=0x592d38 for VHOST: localhost
[Sun Oct 07 05:41:39 2007] [info] APR LDAP: Built with Microsoft Corporation. LDAP SDK
[Sun Oct 07 05:41:39 2007] [info] LDAP: SSL support unavailable: LDAP: CA certificates cannot be set using this method, as they are stored in the registry instead.
[Sun Oct 07 05:41:39 2007] [info] Init: Seeding PRNG with 136 bytes of entropy
[Sun Oct 07 05:41:40 2007] [info] Loading certificate & private key of SSL-aware server
[Sun Oct 07 05:41:40 2007] [debug] ssl_engine_pphrase.c(469): unencrypted RSA private key - pass phrase not required
[Sun Oct 07 05:41:40 2007] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Sun Oct 07 05:41:42 2007] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Sun Oct 07 05:41:42 2007] [debug] ssl_scache_dbm.c(409): Inter-Process Session Cache (DBM) Expiry: old: 0, new: 0, removed: 0
[Sun Oct 07 05:41:42 2007] [info] Init: Initializing (virtual) servers for SSL
[Sun Oct 07 05:41:42 2007] [info] Configuring server for SSL protocol
[Sun Oct 07 05:41:42 2007] [debug] ssl_engine_init.c(405): Creating new SSL context (protocols: SSLv2, SSLv3, TLSv1)
[Sun Oct 07 05:41:42 2007] [debug] ssl_engine_init.c(601): Configuring permitted SSL ciphers [ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL]
[Sun Oct 07 05:41:42 2007] [debug] ssl_engine_init.c(729): Configuring RSA server certificate
[Sun Oct 07 05:41:42 2007] [debug] ssl_engine_init.c(768): Configuring RSA server private key
[Sun Oct 07 05:41:42 2007] [info] Server: Apache/2.2.4, Interface: mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Sun Oct 07 05:41:43 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3 configured -- resuming normal operations
[Sun Oct 07 05:41:43 2007] [notice] Server built: Mar 5 2007 11:23:00
[Sun Oct 07 05:41:43 2007] [notice] Parent: Created child process 1744
[Sun Oct 07 05:41:43 2007] [debug] mpm_winnt.c(481): Parent: Sent the scoreboard to the child
[Sun Oct 07 05:41:43 2007] [error] (OS 11004)The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for. : Could not resolve host name local.celticmemory.bounceme.net -- ignoring!
Warning: DocumentRoot [C:/xampp/celtic/] does not exist
[Sun Oct 07 05:41:43 2007] [error] (OS 11004)The requested name is valid and was found in the database, but it does not have the correct associated data being resolved for. : Could not resolve host name local.wkb.myvnc.com -- ignoring!
Warning: DocumentRoot [C:/xampp/wkb/] does not exist
[Sun Oct 07 05:41:43 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:43 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:43 2007] [info] Init: Seeding PRNG with 136 bytes of entropy
[Sun Oct 07 05:41:45 2007] [info] Loading certificate & private key of SSL-aware server
[Sun Oct 07 05:41:45 2007] [debug] ssl_engine_pphrase.c(469): unencrypted RSA private key - pass phrase not required
[Sun Oct 07 05:41:45 2007] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Sun Oct 07 05:41:47 2007] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Sun Oct 07 05:41:47 2007] [debug] ssl_scache_dbm.c(409): Inter-Process Session Cache (DBM) Expiry: old: 0, new: 0, removed: 0
[Sun Oct 07 05:41:47 2007] [info] Init: Initializing (virtual) servers for SSL
[Sun Oct 07 05:41:47 2007] [info] Configuring server for SSL protocol
[Sun Oct 07 05:41:47 2007] [debug] ssl_engine_init.c(405): Creating new SSL context (protocols: SSLv2, SSLv3, TLSv1)
[Sun Oct 07 05:41:47 2007] [debug] ssl_engine_init.c(601): Configuring permitted SSL ciphers [ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL]
[Sun Oct 07 05:41:48 2007] [debug] ssl_engine_init.c(729): Configuring RSA server certificate
[Sun Oct 07 05:41:48 2007] [debug] ssl_engine_init.c(768): Configuring RSA server private key
[Sun Oct 07 05:41:48 2007] [info] Server: Apache/2.2.4, Interface: mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Sun Oct 07 05:41:48 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:48 2007] [warn] NameVirtualHost 127.0.0.1:80 has no VirtualHosts
[Sun Oct 07 05:41:48 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x590b78 rmm=0x590ba0 for VHOST: localhost
[Sun Oct 07 05:41:48 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x590b78 rmm=0x590ba0 for VHOST: local.wkb.myvnc.com
[Sun Oct 07 05:41:48 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x590b78 rmm=0x590ba0 for VHOST: local.celticmemory.bounceme.net
[Sun Oct 07 05:41:48 2007] [debug] util_ldap.c(1942): LDAP merging Shared Cache conf: shm=0x590b78 rmm=0x590ba0 for VHOST: localhost
[Sun Oct 07 05:41:48 2007] [info] APR LDAP: Built with Microsoft Corporation. LDAP SDK
[Sun Oct 07 05:41:48 2007] [info] LDAP: SSL support unavailable: LDAP: CA certificates cannot be set using this method, as they are stored in the registry instead.
[Sun Oct 07 05:41:48 2007] [info] Init: Seeding PRNG with 136 bytes of entropy
[Sun Oct 07 05:41:49 2007] [info] Loading certificate & private key of SSL-aware server
[Sun Oct 07 05:41:49 2007] [debug] ssl_engine_pphrase.c(469): unencrypted RSA private key - pass phrase not required
[Sun Oct 07 05:41:49 2007] [info] Init: Generating temporary RSA private keys (512/1024 bits)
[Sun Oct 07 05:41:52 2007] [info] Init: Generating temporary DH parameters (512/1024 bits)
[Sun Oct 07 05:41:52 2007] [debug] ssl_scache_dbm.c(409): Inter-Process Session Cache (DBM) Expiry: old: 0, new: 0, removed: 0
[Sun Oct 07 05:41:52 2007] [info] Init: Initializing (virtual) servers for SSL
[Sun Oct 07 05:41:52 2007] [info] Configuring server for SSL protocol
[Sun Oct 07 05:41:52 2007] [debug] ssl_engine_init.c(405): Creating new SSL context (protocols: SSLv2, SSLv3, TLSv1)
[Sun Oct 07 05:41:52 2007] [debug] ssl_engine_init.c(601): Configuring permitted SSL ciphers [ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL]
[Sun Oct 07 05:41:52 2007] [debug] ssl_engine_init.c(729): Configuring RSA server certificate
[Sun Oct 07 05:41:52 2007] [debug] ssl_engine_init.c(768): Configuring RSA server private key
[Sun Oct 07 05:41:52 2007] [info] Server: Apache/2.2.4, Interface: mod_ssl/2.2.4, Library: OpenSSL/0.9.8e
[Sun Oct 07 05:41:52 2007] [notice] Child 1744: Child process is running
[Sun Oct 07 05:41:52 2007] [debug] mpm_winnt.c(402): Child 1744: Retrieved our scoreboard from the parent.
[Sun Oct 07 05:41:52 2007] [info] Parent: Duplicating socket 208 and sending it to child process 1744
[Sun Oct 07 05:41:52 2007] [info] Parent: Duplicating socket 192 and sending it to child process 1744
[Sun Oct 07 05:41:52 2007] [debug] mpm_winnt.c(599): Parent: Sent 2 listeners to child 1744
[Sun Oct 07 05:41:52 2007] [debug] mpm_winnt.c(558): Child 1744: retrieved 2 listeners from parent
[Sun Oct 07 05:41:52 2007] [notice] Child 1744: Acquired the start mutex.
[Sun Oct 07 05:41:52 2007] [notice] Child 1744: Starting 250 worker threads.
[Sun Oct 07 05:41:52 2007] [notice] Child 1744: Starting thread to listen on port 443.
[Sun Oct 07 05:41:52 2007] [notice] Child 1744: Starting thread to listen on port 80.


I am really stumped here, On this machine the server I can view either vhost by typing localhost/wkb etc and I can view the site, but if I just type localhost i get the error 403. Now on another computer on this network it is opposite. I can type in my url and see the main site, but if I type in the url of the other sites I get this error Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'root'@'localhost' (using password: YES) in C:\xampp\htdocs\phpbb\db\mysql4.php on line 48

Warning: mysql_error(): supplied argument is not a valid MySQL-Link resource in C:\xampp\htdocs\phpbb\db\mysql4.php on line 330

Warning: mysql_errno(): supplied argument is not a valid MySQL-Link resource in C:\xampp\htdocs\phpbb\db\mysql4.php on line 331
phpBB : Critical Error

Could not connect to the database
VampInc
 
Posts: 3
Joined: 07. October 2007 10:01

Postby VampInc » 07. October 2007 10:52

My vhost file in case you need it.

NameVirtualHost 127.0.0.1:80

<VirtualHost 127.0.0.1:80>
DocumentRoot /
ServerName localhost
ServerAlias vampinc.com *.vampinc.com
ServerAdmin admin@localhost
</VirtualHost>

<VirtualHost local.celticmemory.bounceme.net:80>
DocumentRoot /xampp/celtic/
ServerName local.celticmemory.bounceme.net
Serveralias celticmemory.bounceme.net *.celticmemory.bounceme.net
ServerAdmin admin@local.celticmemory.bounceme.net
<Directory "/xampp/celtic/">
Options Indexes FollowSymLinks
AllowOverride FileInfo
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
NameVirtualHost 127.0.0.1:80

<VirtualHost local.wkb.myvnc.com:80>
DocumentRoot /xampp/wkb/
ServerName local.wkb.myvnc.com
Serveralias wkb.myvnc.com *.wkb.myvnc.com
ServerAdmin admin@local.wkb.myvnc.com
<Directory "/xampp/cwkb/">
Options Indexes FollowSymLinks
AllowOverride FileInfo
Order allow,deny
Allow from all
</Directory>
</VirtualHost>
NameVirtualHost 127.0.0.1:80
VampInc
 
Posts: 3
Joined: 07. October 2007 10:01

Postby terry_opie » 14. February 2008 03:17

Ever find a solution to this?
terry_opie
 
Posts: 1
Joined: 14. February 2008 02:45

Postby Izzy » 14. February 2008 04:57

terry_opie wrote:Ever find a solution to this?


This thread is old in relative terms for this dynamic forum and so you may not get a reply from the OP - VampInc.
Unless the OP has anymore errors, then VampInc may never visit these forums again.

So if you have a similar 403 error issue, first look in the server's error.log file about the time you get your error, and if you can't understand it, paste it here so we can take a look at it for you - all 403 errors are not necessarily the same.
.\xampp\apache\logs\error.log

If you have configured and if you have errors in your httpd-vhosts.conf file, like the many errors in the above pasted httpd-vhosts.conf file, then paste the file here so we can take a look at it for you.
.\xampp\apache\conf\extra\httpd-vhosts.conf

In other words give as much detail as possible about what you did to get the error, what the error looks like and what you have perhaps done already to try and fix your issues.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby ninostar » 28. August 2008 16:09

Hello,

I've also get error 403... this is the message that I get in log file:
[Thu Aug 28 17:06:47 2008] [error] [client 84.52.161.146] client denied by server configuration: C:/xampp/www/
ninostar
 
Posts: 10
Joined: 17. July 2008 13:14

Error 403 Forbidden

Postby twbeebe » 29. August 2008 18:53

I am running an internal XP Pro w/ IIS, Test Server, before I publish the site. I too, received the error, but when it told me that the server IP address was 127.0.0.xxx, I ran IPCONFIG from the command prompt, got the true IP address for 'LocalHost', corrected the includes/configure.php file to the true IP address and my issues have gone away.

The lines corrected were ;

define('HTTP_SERVER', 'http://192.168.0.10');
define('HTTPS_SERVER', 'https://192.168.0.10');

I am expecting to have to change these once I publish, but only to the true IP address that my Host machine will be using.

There also seems to be another file, that includes four lines that need to be changed, very similar to the above, but it escapes me now for which one, sorry. I will update this post, once I find the file again.
twbeebe
 
Posts: 5
Joined: 25. May 2008 17:31
Location: Penryn, CA


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests