MySQL won't run as a service.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL won't run as a service.

Postby Bert » 02. October 2003 12:16

I want to start MySQL automatic when windows runs.
But then it won't work...
I must start the deamon (dos window) to run the sql program.
how can i start it as a service?
I tryed many times to instal it as a service with the batch program...

Who can help me?

Thanks,
Bert
Bert
 

Postby Kristian Marcroft » 02. October 2003 12:38

Hi,

did you copy the my.cnf to C:\
please d so, and edit the Paths in the my.cnf
Cos it needs to be on System Root when you want it to run as a service.

So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Bert » 02. October 2003 14:04

KriS wrote:Hi,

did you copy the my.cnf to C:\
please d so, and edit the Paths in the my.cnf
Cos it needs to be on System Root when you want it to run as a service.

So long
KriS


I did. But it won't work.
I have the latest version of xampp and installed in c:\xampp

The my.cnf file:

# The MySQL client
[client]
#password = your_password
port = 3306
socket = C:/xampp/mysql/mysql.sock

# Here follows entries for some specific programs

# The MySQL server
[mysqld]
port = 3306
socket = C:/xampp/mysql/mysql.sock
skip-locking
set-variable = key_buffer=16M
set-variable = max_allowed_packet=1M
set-variable = table_cache=64
set-variable = sort_buffer=512K
set-variable = net_buffer_length=8K
set-variable = myisam_sort_buffer_size=8M
log-bin
server-id = 1

basedir=C:/xampp/mysql
tmpdir=C:/xampp/tmp
datadir=C:/xampp/mysql/data

#bind-address=192.168.1.1
#log-update = /path-to-dedicated-directory/hostname

# Uncomment the following if you are using BDB tables
#set-variable = bdb_cache_size=4M
#set-variable = bdb_max_lock=10000

skip-innodb
# Uncomment the following if you are using InnoDB tables
#innodb_data_home_dir = C:/xampp/mysql/
#innodb_data_file_path = ibdata1:10M:autoextend
#innodb_log_group_home_dir = C:/xampp/mysql/
#innodb_log_arch_dir = C:/xampp/mysql/
# You can set .._buffer_pool_size up to 50 - 80 %
# of RAM but beware of setting memory usage too high
#set-variable = innodb_buffer_pool_size=16M
#set-variable = innodb_additional_mem_pool_size=2M
# Set .._log_file_size to 25 % of buffer pool size
#set-variable = innodb_log_file_size=5M
#set-variable = innodb_log_buffer_size=8M
#innodb_flush_log_at_trx_commit=1
#set-variable = innodb_lock_wait_timeout=50

[mysqldump]
quick
set-variable = max_allowed_packet=16M

[mysql]
no-auto-rehash
# Remove the next comment character if you are not familiar with SQL
#safe-updates

[isamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[myisamchk]
set-variable = key_buffer=20M
set-variable = sort_buffer=20M
set-variable = read_buffer=2M
set-variable = write_buffer=2M

[mysqlhotcopy]
interactive-timeout

[WinMySQLadmin]
Server=C:/xampp/mysql/bin/mysqld-nt.exe

This is good i think...

What is my problem...
If i want to start the service manualy, i get error 1067.
It won't start...

Thanks for an answer,
Bert
Bert
 

Postby Bert » 02. October 2003 14:56

Oh..........

I fixed the problem.
I searched this forum, and found an anser is deutch.. ;)
I deleted the my.ini in the windows folder, reinstalled the service, and i had rebooted by computer.

IT WORKS!!!! WHEE

Thanksss
Bert
 


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests