Apache problem with Panda Antivirus + Firewall

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache problem with Panda Antivirus + Firewall

Postby rfidalgo » 17. September 2007 21:46

I downloaded and unzip the file xampplite-win32-1.6.3a.zip.
I run setup_xampp.bat but when i run apache_start.bat i had got a problem. Apache_start displayed the message below:

-------------------------

Diese Eingabeforderung nicht waehrend des Running beenden
Bitte erst bei einem gewollten Shutdown schliessen
Please close this command only for Shutdown
Apache 2 is starting ...
(OS 10048)S¾lo se permite un uso de cada direcci¾n de socket (protocolo/direcci¾
n de red/puerto) : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Apache konnte nicht gestartet werden
Apache could not be started
Presione una tecla para continuar . . .

------------------------------

I have installed Panda Antivirus + Firewall. I think there is a conflic to use the port 80 between Apache and Panda program.

can i fix the problem without change Apache's port 80?
Thanks in advance.

Rafa.
rfidalgo
 
Posts: 3
Joined: 17. September 2007 21:30
Location: Madrid

Postby Wiedmann » 17. September 2007 22:04

There is another Server running on port 80. You can use xampp_portcheck or netstat to find this program. Stop this program and you can start Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rfidalgo » 18. September 2007 23:08

Thanks for your fast answer.
But i am afraid i can stop the program which use port 80 because it is antivirus program.

But at the same time i asked this forum also i asked Technical support Panda the same question and they replied me that i had to change my current product "Panda Antivirus + Firewall 2007" to "Panda Internet Security 2008".

The only product I will be able to set port for Apache is with "Panda Internet Security 2008".

Really I don´t understand why i have to change for other product more expensive to use the port 80 and 443.

I don´t know if there is some other antivirus product which allow me to use ther port 80 and 443.

Thx again
rfidalgo
 
Posts: 3
Joined: 17. September 2007 21:30
Location: Madrid

Postby Wiedmann » 19. September 2007 00:18

But i am afraid i can stop the program which use port 80 because it is antivirus program.

That's really your antivirus software which is using port 80 (as server) and you can't prevent this software from using this port? (you have verified this with netstat or tcpview or xampp-portcheck?)

Then IMHO that's a good reason to use a product from an other manufacturer...


I don´t know if there is some other antivirus product which allow me to use ther port 80 and 443.

Well, there are often problems with antivirus/firwall software and Apache, if the software change the Windows TCP/IP stack in an unwanted way. But I don't know any antivirus software which is /using/ this port (see the Apache error message).

BTW error message:
Does this "S¾lo se permite un uso de cada direcci¾n de socket " mean:
"Only one usage of each socket address is normally permitted"?

BTW:
The firewall from Windows or McAfee and McAfee AntiVirus have no problem with Apache. Avira AntiVir and AVG Anti-Virus have also no problems (after a quick test).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby rfidalgo » 19. September 2007 22:17

Sorry, I made a mistake.

I followed your advice, I run xampp-portcheck and i found out that Skype was running on port 80 and 443.

I look into options zone of Skype and i remove a option that it do Skype to use port 80 and 443.

I made a mistake because i run "telnet 127.0.0.1 80" to connect with server, after that i run netstat command to find out what program was running on port 80. Netstat showed me that Webproxy was running on port 80. WebProxy is a program from my antivirus-firewall.

Now, I think Skype was behind of WebProxy and that was the problem.

I am sorry. My excuses to Panda.

Thx, for all.
rfidalgo
 
Posts: 3
Joined: 17. September 2007 21:30
Location: Madrid

Re: Apache problem with Panda Antivirus + Firewall

Postby AlexanderJ » 25. May 2010 19:25

If you disable Panda Antivirus Firewall apache will work normal, Panda antivirus make the same problem even now in 2010, will block port 80, I recommend you all to install any other free antivirus program try http://www.trustdownload.com/Antivirus-and-Spyware-Cleaners/Antivirus/AVG-Anti-Virus-9-Free-Edition.html AVG Free, avira, norton antivirus.
AlexanderJ
 
Posts: 1
Joined: 25. May 2010 19:15

Re: Apache problem with Panda Antivirus + Firewall

Postby timkat » 26. July 2010 14:51

Panda antivirus it's ok, but if you don't like it or if you feel that it isn't doing its job quite well, you might want to change it. If so, I suggest you to try to use something better. In order to find the perfect one for you, you might want to have a look on these antivirus reviews, to see what is the best one.
timkat
 
Posts: 1
Joined: 26. July 2010 14:41


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests