New XAMPP install on Vista + uncomment cURL = CRASH ???

Problems with the Windows version of XAMPP, questions, comments, and anything related.

New XAMPP install on Vista + uncomment cURL = CRASH ???

Postby brentos » 14. September 2007 18:39

I've been using Lampserver for the past few months or so for localhost development but needed to install cURL and SSL support for a site i'm working on.

Uninstalled Lampserver, d/l'd XAMPP for windows yesterday and installed it.

The only thing i changed in the config files was to add my email address:
; For Win32 only.
sendmail_from =

Everything worked great, i like how the interface looks and functions, no problems, SSL worked fine which was VERY nice to see. But then i uncomment this:


And then apache crashes and won't restart.
Doesn't give any error messages, just says :

"Apache is starting..."

then does nothing. Little indicator in the control panel still says "stopped".

if i re-comment it out again:

then life and the multiverse is great once again.

Any ideas ???

Any help is greatly greatly appreciated.

Last edited by brentos on 15. September 2007 21:22, edited 1 time in total.
Posts: 2
Joined: 14. September 2007 18:10
Location: British Columbia, Canada

Postby Izzy » 15. September 2007 01:43

I would edit your post and remove your actual email address as email address collecting spam bots often scour forums for just that purpose.

Also I do not have Vista to test this on only XP Pro so it may be an exclusive Vista issue.

I have heard tell that the Vista Administrator is all powerful and it often requires you to be in that mode to do anything remotely useful.

I just tried to reproduce this issue on my XP Pro XAMPP installation set to default configs without success.

phpinfo() reveals that
Curl support - Enabled
Curl Information - libcurl/7.16.0 OpenSSL/0.9.8e zlib/1.2.3

When I comment out extension=php_curl.dll in xampp\apache\bin\php.ini then the Curl information in phpinfo() is no longer showing so all is working as it should.

Couple of things to check as you had a previous ampp installation.

Make sure that no other instance of any of the previous ampp components are still installed as services or being loaded before any of the XAMPP components, as XAMPP likes exclusive use of the ports it uses.

Do this by checking using Windows Task Manager (right click on the Taskbar and select it the the Processes tab) before starting any of the XAMPP components.

Also you could do the same by running xampp\xampp-portcheck.exe before starting any XAMPP components and again after you have started XAMPP.

Check the xampp\apache\logs\error.log file for any clues.

Instead of using the XAMPP Control Panel try starting Apache using the xampp\apache_start.bat file as it may tell you why it is not being allowed to start.

To check that the httpd.conf file syntax is not allowing Apache to start:
Open a command prompt in xampp\apache\bin and type this command apache -t then hit Enter:

If all else fails to fix this issue then try completely uninstalling XAMPP.
Re-install using a different method by downloading the 7zip version perhaps.

Take a look at the new DeskTopXampp launch control for XAMPP and XAMPPlite (DTX.exe)
posted by ridgewood: ... 967#103967
Also available here:
I highly recommend DTX.
Posts: 3344
Joined: 25. April 2006 17:06

Postby brentos » 15. September 2007 21:26

Thanks for the response.

I did try using portcheck.exe
it crashed as well.

Aafter finding nothing that could indicate where the problem was, i uninstalled and reinstalled and everything works great.

i guess planetary alignment or some other obscure event screwed up my initial install :\
Posts: 2
Joined: 14. September 2007 18:10
Location: British Columbia, Canada

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests