Unable to start the xampp 2.0

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Unable to start the xampp 2.0

Postby NEWGEN » 01. September 2007 07:00

Hi,
Under win98,
i installed xampp; apache 2.0 when started, starts for a few mins, and later stops,
can anybody advise what to do?

thanks
newgen

The following is the error log
[fri aug 25 21:54:20 2000][crit](22)Invalid argument unable to replace stderr with error_log
[fri aug 25 21:54:20 2000][crit](2) No such file or directory unable to replace stderr with/dev/null
[fri aug 25 21:54 20 2000][notice] Digest generating secret for digest authentication...
[fri aug 25 21:54 20 2000][crit](-214617381)Unknown erroryeDigest:error generatinmgsecret:unknowerror
[fri aug 25 21:54 20 2000][crit](22) Invalid argument unable to replace stderr withh error_log
[fri aug 25 21:54 20 2000][crit](2) No such file or directory unable to replace stderr with /dev/null
[fri aug 25 21:54 20 2000][crit](22)Invalid argument unable to replace stderr with error_log
[fri aug 25 21:54 20 2000][crit](2) No such file or directory.unable to replace stderr with /dev/null
[fri aug 25 21:54 20 2000][notice]Digest generating secret for digest authentication...
[fri aug 25 21:54 20 2000][crit](-2146173818)unknow error.Digest:error generating secret:unknow error
NEWGEN
 
Posts: 2
Joined: 01. September 2007 06:07

Postby Izzy » 01. September 2007 08:16

The error log entry is several days old.

Any chance of seeing a more current entry after an attempted start.

I am not sure what the Digest errors in the log file are as some are only notices and others are critical.

Perhaps a forum (using the English Forums) and or Google search for Digest might come up with some answers.

The other errors that are not Digest related are normal and can be ignored.

You can see if there are any ports that XAMPP needs being used by other applications like Skype or Microsoft's Internet Information Server IIS.
Double click on xampp\xampp-portcheck.exe
It will list the ports and if they are free or what applications are using the ports.

Another thing you could try is starting Apache using the xampp\apache_start.bat after stopping all previous instances that might be running in the XAMPP Control Panel, then close the control panel.

The bat file will display any errors it encounters whilst trying to start.

Paste any other errors you find or any more clues that spring to mind that you are not sure about.

Check your firewall and or anti-virus software is not interfering by temporarily suspending them.

Turn them back on again if they do not affect Apache start up.

Investigate why if they do affect Apache.

There is mention of a Winsock issue on older Windows OSs here:
http://www.apachefriends.org/en/faq-xam ... ml#nostart

I must admit it has been a long time since I had my hands on a Win98 OS :wink:
HTH

=================================================
Take a look at the new DeskTopXampp launch control posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967

The DeskTopXampp launch control for XAMPP and XAMPPlite (DTX.exe)
is available here:
http://zedfiles.com/DTX/

I highly recommend DTX.
=================================================
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Thanks for your reply

Postby NEWGEN » 04. September 2007 14:16

The error log entry is several days old.
Please ignore the date(year) since i had changed the date to install a software; it is the recent date(aug 25 21:54:20 2007)

You can see if there are any ports that XAMPP needs being used by other applications like Skype or Microsoft's Internet Information Server IIS.
Double click on xampp\xampp-portcheck.exe

No other application is running on any other port;
No other server has been installed
System not connected to the internet, hmmm shall we say no connection
Checked it through tcpview.exe; found nothing


Another thing you could try is starting Apache using the xampp\apache_start.bat after stopping all previous instances that might be running in the XAMPP Control Panel, then close the control panel.
I did that too, the command prompt says "apache 2.0 starting" and that all..

Check your firewall and or anti-virus software is not interfering by temporarily suspending them.
no firewall, no symantec, no norton antivirus

There is mention of a Winsock issue on older Windows OSs here:
http://www.apachefriends.org/en/faq-xam ... ml#nostart


As for as winsock; i don't know whether there is a problem in it or not!

I want to work on php; can you suggest any other opensource webserver which is compatible to php and works on win98?
NEWGEN
 
Posts: 2
Joined: 01. September 2007 06:07

This error also on Win XP home

Postby Roberto Trama » 21. September 2007 10:41

I receive the same errors when I load xampp by the control panel on my Win XP SP2:

----------------Begin 1
[Fri Sep 21 11:09:48 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Sep 21 11:09:48 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Sep 21 11:09:49 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Sep 21 11:09:49 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Sep 21 11:09:51 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3 configured -- resuming normal operations
[Fri Sep 21 11:09:51 2007] [notice] Server built: Mar 5 2007 11:23:00
[Fri Sep 21 11:09:51 2007] [notice] Parent: Created child process 3604
----------------End 1

But it seems to not affect the normal functionality of the web server. I noticed these errors only because looking for another thing in the error log.

When I load Apache by the .bat file I do not receive any error:

----------------Begin 2
[Fri Sep 21 11:14:17 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.3 configured -- resuming normal operations
[Fri Sep 21 11:14:17 2007] [notice] Server built: Mar 5 2007 11:23:00
[Fri Sep 21 11:14:17 2007] [notice] Parent: Created child process 508
[Fri Sep 21 11:14:18 2007] [notice] Child 508: Child process is running
[Fri Sep 21 11:14:18 2007] [notice] Child 508: Acquired the start mutex.
[Fri Sep 21 11:14:18 2007] [notice] Child 508: Starting 250 worker threads.
[Fri Sep 21 11:14:18 2007] [notice] Child 508: Starting thread to listen on port 443.
[Fri Sep 21 11:14:18 2007] [notice] Child 508: Starting thread to listen on port 80.
----------------End 2

So maybe there is something wrong with the graphical control panel.

With the last version I also receive an error with a category mismatch: it looks for an install directory, but i run xampp manually, without installation

Hope this may be of any help.
Best regards
Roberto
Roberto Trama
 
Posts: 2
Joined: 30. March 2006 11:52

Invalid argument: unable to replace stderr with error_log

Postby vsvnmurthy » 11. April 2008 08:44

Hi there!..

I am using Xampp on WindowsXP. It was working fine with joomla CMS..
Recently I have loaded one more open source SUGARCRM..The loading is completed.. When ever i do certain action on SUGARCRM..like tab navigation ... Submitting a form..etc..
I get the Subject Error. For few seconds.. apache will close.. and says ..
apache is busy or stopped.. will restart in few seconds..
Again it will start.. but not posting the values..

I would like to inform that with JOOMLA CMS it is working fine now also..The problem is only with SUGARCRM.

Please guide me if you have any solution..

Thanks..
vsvnmurthy
 
Posts: 1
Joined: 11. April 2008 08:37


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests