Error/Mcrypt

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Error/Mcrypt

Postby RedXIII » 15. August 2007 05:40

I am receiving the "Cannot load mcrypt extension. Please check your PHP configuration." error in phpMyAdmin.

I confirmed that my php extension dir is set correctly, and the mcrypt extension is uncommented in both php.ini files.

I turned on the php error log, and I received the following error, which I do not understand.

[14-Aug-2007 22:29:46] PHP Warning: PHP Startup: SVWj: Unable to initialize module
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP compiled with module API=20060613, debug=0, thread-safety=1
These options need to match
in Unknown on line 0

Any ideas?
RedXIII
 
Posts: 6
Joined: 09. August 2007 10:23

Postby Izzy » 15. August 2007 05:55

You only need to uncomment it one php.ini file and that one is in:
xampp\apache\bin\php.ini

This is the only php.ini file you need to worry about in a default installation of XAMPP.

You can check the php.ini location by selecting phpinfo() from the XAMPP welcome page menu in the left hand frame.

HTH

=================================================
Take a look at the new DeskTopXampp launch control posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967

The DeskTopXampp launch control for XAMPP and XAMPPlite (DTX.exe)
is available here:
http://zedfiles.com/DTX/

I highly recommend DTX.
=================================================
Last edited by Izzy on 02. September 2007 04:16, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby RedXIII » 15. August 2007 06:06

That is what I thought, but I read somewhere that uncommented both of them will fix the issue. I suppose that is incorrect.

Even when I uncomment it in the one .ini and leave the other alone, the issue remains.

Any other ideas?
Thanks
RedXIII
 
Posts: 6
Joined: 09. August 2007 10:23

Postby Izzy » 15. August 2007 06:17

RedXIII wrote:That is what I thought, but I read somewhere that uncommented both of them will fix the issue. I suppose that is incorrect.

Even when I uncomment it in the one .ini and leave the other alone, the issue remains.

Any other ideas?
Thanks

What is the location of the php.ini file you are uncommenting in?

When you have uncommented the correct php.ini file that is in the directory I pointed you to in my first reply, you can then look in the phpinfo() page, I also mention above and check if MyCrypt is indeed enabled.

You should see something like this (in a fancy table) when it is correctly enabled:

mcrypt
mcrypt support enabled
Version 2.5.7
Api No 20021217
Supported ciphers cast-128 gost rijndael-128 twofish arcfour cast-256 loki97 rijndael-192 saferplus wake blowfish-compat des rijndael-256 serpent xtea blowfish enigma rc2 tripledes
Supported modes cbc cfb ctr ecb ncfb nofb ofb stream


=================================================
Take a look at the new DeskTopXampp launch control posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967

The DeskTopXampp launch control for XAMPP and XAMPPlite (DTX.exe)
is available here:
http://zedfiles.com/DTX/

I highly recommend DTX.
=================================================
Last edited by Izzy on 02. September 2007 04:23, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby RedXIII » 15. August 2007 06:45

I'm editing the reported configuration file 'C:\xampp\apache\bin\php.ini'.

I do not see the mcrypt chart. Although, I do see mcrypt_filter.
RedXIII
 
Posts: 6
Joined: 09. August 2007 10:23

Postby Izzy » 15. August 2007 06:54

RedXIII wrote:I'm editing the reported configuration file 'C:\xampp\apache\bin\php.ini'.

I do not see the mcrypt chart. Although, I do see mcrypt_filter.

I don't see an mcrypt_filter in my phpinfo() page.

What does this line tell you in your phpinfo() page?
Loaded Configuration File

=================================================
Take a look at the new DeskTopXampp launch control posted by ridgewood:
http://community.apachefriends.org/f/viewtopi ... 967#103967

The DeskTopXampp launch control for XAMPP and XAMPPlite (DTX.exe)
is available here:
http://zedfiles.com/DTX/

I highly recommend DTX.
=================================================
Last edited by Izzy on 02. September 2007 04:27, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby RedXIII » 15. August 2007 21:44

Loaded Configuration File C:\xampp\apache\bin\php.ini

I enabled mcrypt_filter in php.ini to check if it was needed. Makes no difference with it enabled or disabled.

I did some testing, and when I disabled mcrypt in php.ini, the error message no longer appeared. Do you have any idea what that error means? Do I somehow have an incompatible version of mcrypt?

edit: I downloaded the Xampp.zip installation, and replace all of the .dll files in the php root, ext and extension folders. After I replaced the files, I rebooted apache, and the error message was gone in the log, and on phpMyAdmin. As I guessed, I must of had a incorrect/corrupt version of mcrypt.

Thanks for your assistance.
RedXIII
 
Posts: 6
Joined: 09. August 2007 10:23


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests