Can't start Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't start Apache

Postby tsmike » 05. August 2007 19:08

Hi there.
I can't seem to start Apache from the Control panel. Well, it would start and the running bar would appear...but only for a second or so then it shuts itself off. So I tried starting it with the apache_start DOS in the xampp folder and it came up with this:

Apache 2 is starting...
<OS 10048> Only one of each socket address <protocol/network address/port> is normally permitted. :make sock: could not bind to address 0.0.0.0:433 no listining sockets available, shutting down
Unable to open logs

Apche could not be started.


Annoyingly, I have no idea what that means. Can anyone help?
tsmike
 
Posts: 4
Joined: 05. August 2007 18:50

Postby Wiedmann » 05. August 2007 19:12

Annoyingly, I have no idea what that means.

You have allready another server running. Stop this server and you can start Apache.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tsmike » 05. August 2007 23:38

hmm
Well I've done a bit of port checks and nothing seems to be running on port 80. Even xampp-portcheck says that port 80 is free. Still a no-go.
tsmike
 
Posts: 4
Joined: 05. August 2007 18:50

Postby Wiedmann » 06. August 2007 00:07

and nothing seems to be running on port 80

Just look at the error message:
tsmike wrote:could not bind to address 0.0.0.0:433
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Starting Apache Server, XAMPP (basic package) version 1.6.3

Postby cgiguere » 06. August 2007 03:38

Hello,
I have the same problem as earlier reported, meaning can't start the Apache server. Same error message as Tsmike:

"Only one usage of each socket adress...."

However, they error refers to port :80 (so, not the same as Tsmike).

I have stopped my IIS server, and also stopped SQLserver. Still can't start Apache.

Waiting for your advise.
Cheers,
Christiane
cgiguere
 
Posts: 4
Joined: 06. August 2007 03:27

Postby Wiedmann » 06. August 2007 10:04

I have stopped my IIS server, and also stopped SQLserver. Still can't start Apache.

Use a tool like netstat or xampp_portcheck, to see which program is using port 80.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tsmike » 06. August 2007 11:57

tsmike wrote:could not bind to address 0.0.0.0:433


Right...well how can I check what's using 433? I only know how to monitor ports >_<
tsmike
 
Posts: 4
Joined: 05. August 2007 18:50

Postby cgiguere » 07. August 2007 04:15

Wiedmann wrote:
I have stopped my IIS server, and also stopped SQLserver. Still can't start Apache.

Use a tool like netstat or xampp_portcheck, to see which program is using port 80.


Thank you, it was IIS. I thought I had stopped all services but I obviously had not. Great helpful forum and very happy with I learn in the threads.
Cheers,
Christiane
cgiguere
 
Posts: 4
Joined: 06. August 2007 03:27

Free PHP-IDE

Postby cgiguere » 07. August 2007 04:27

Does anyone knows of a free PHP-IDE? I know of NuSpere and Komodo but these are not free. I would not want to have to type all in a text editor. Would be nice to use an IDE with a test, debug, word completion type of thing.

Waiting for your advise and tks in advance,
Cheers,
Christiane
cgiguere
 
Posts: 4
Joined: 06. August 2007 03:27

Postby tsmike » 08. August 2007 11:44

Well, I figured out my problem. The error was on port 443 not 433. >_<
...and I can't use port 433, beause AOL uses it for something :(

Now there's 2 reasons to get a new ISP -.-
tsmike
 
Posts: 4
Joined: 05. August 2007 18:50

Port 443 and SSL

Postby ridgewood » 08. August 2007 14:29

Apache needs to bind to all of the ports that are named in httpd.conf

You can give this a try... if you do not need SSL...edit your httpd.conf, (around line 519) with '#Include conf/extra/httpd-ssl.conf' this will keep Apache from calling to the port 443.

If you need SSL, it looks like either a previous install or another program is binding to 443, so you will have to go into 'conf/extra/httpd-ssl.conf ' and try using a different port.
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02

Postby RedXIII » 09. August 2007 10:32

I have a similar issue, and cannot figure it out. It works fine, but after a few hours, the service eventually dies, and I get an error message when I restart it.

Code: Select all
(OS 10048)Only one usage of each socket address protocol/network address/port) is normally permitted.  : make_sock: could not bind to address 0.0.0.0:80 no listening sockets available, shutting down
Unable to open logs


No matter what I do, I cannot restart the service, unless I restart my pc. Once I do restart my PC, once again it works fine, but a few hours later, the service dies and the cycle starts again.

I have checked my ports using several methods, and I can confirm that port 80 has nothing running on it.

Any ideas?

edit: I changed nothing since the time I made this post, but all of a sudden, the problem disappeared. Bizarre.
Last edited by RedXIII on 15. August 2007 05:32, edited 1 time in total.
RedXIII
 
Posts: 6
Joined: 09. August 2007 10:23

Some Information Please

Postby ridgewood » 09. August 2007 12:33

I'm not quite sure that it is the same problem... but we can give it a shot :?

What operating system, version of XAMPP and did you use the installer or build from a zip file? Have you installed other versions of XAMPP on this system before...or other WAMP stacks?

Since it does start and work for a while... can you open the error.log in apache/logs?

In the mean time, try using the xampp-control and stop apache and uncheck the 'service' so that it uninstalls it... then restart Apache...then check the status.

OK?
ridgewood
 
Posts: 57
Joined: 10. January 2005 22:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests