Warning : Directory mismatch when I lauch xampp-control.exe

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby hotdogs » 26. November 2008 14:20

I'm having the same problem.........

BUT NEVER EVER USE AMPSTART... IT'S FULL OF NASTY STUFF!!!

A-Squared Found: Backdoor.Win32.Hupigon!IK
ClamAV Found: Trojan.Spy.Banker-6225
CPsecure Found: Troj.Spy.W32.Banbra.kp
Ikarus Found: Trojan-Spy.Win32.Banker.AHZ

Don't believe me? Archive the file and load it here http://virusscan.jotti.org

Please excuse me, but lyntuan you are a piece of S#!T!
help out the new guy!
hotdogs
 
Posts: 9
Joined: 20. May 2008 15:39

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby richdorfman » 10. February 2009 04:02

Thanks Draven. I have several copies of xampp and need to switch back and forth for various development tasks. I found there are 3 registry entries in Win XP that I need to set for each different copy of xampp. So I made separate .reg files for each set of registry keys and simply double click the .reg file I need before starting the servers.

For example, here is xampp3.reg. The usually caveats apply before you make modifications to your registry and you will need to customize this file depending on the locations of your own installation.

Code: Select all
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\PHP]
"IniFilePath"="K:\\xampp3\\apache\\bin\\"

[HKEY_LOCAL_MACHINE\SOFTWARE\xampp]
"Install_Dir"="K:\\xampp3"

[HKEY_LOCAL_MACHINE\SOFTWARE\Zend Technologies\Zend Optimizer]
"ServerRoot"="K:\\xampp3\\apache\\"
richdorfman
 
Posts: 2
Joined: 10. February 2009 03:54

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby Izzy » 10. February 2009 04:17

You can if you wish completely ignore the Directory Mismatch message as it has no effect on the running of XAMPP or the running or functions of the XAMPP Control Panel.

I too have many versions of XAMPP installed for the testing of posters issues and the message in the XCP has no effect on those XAMPP installations what so ever - I can switch from one version to another including the several versions of the XCP without issue or having to edit the registry, providing of course I don't try to run more than one instance of any of them at a time which has nothing to do with the Directory Mismatch message.

So removing the message by adding Draven's unnecessary registry entries is a personal choice and not mandatory - it really is just another unnecessary piece of registry clutter, as if there is not enough of that created by Windows and mindless software developers anyway, which would have to be manually removed when and if required.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby richdorfman » 11. February 2009 18:26

Izzy wrote:I too have many versions of XAMPP installed for the testing of posters issues and the message in the XCP has no effect on those XAMPP installations what so ever - I can switch from one version to another including the several versions of the XCP without issue or having to edit the registry, providing of course I don't try to run more than one instance of any of them at a time which has nothing to do with the Directory Mismatch message.

That has not been my experience. When there was a mismatch with the first registry key cited in my previous post, the wrong php.ini file got loaded and as there were different versions of php between the two installations, my code produced many php errors.

When the second registry entry mismatched, phpadmin did not run. I'm not sure if the Zend key has any effect but I threw that in for good measure.
richdorfman
 
Posts: 2
Joined: 10. February 2009 03:54

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby akie43 » 16. April 2009 10:21

If you are running a 64bit version of Windows, the registry key as described by Draven is incorrect!

Draven wrote:So, by looking at the code, you can see that this value is located at :

HKEY_LOCAL_MACHINE\SOFTWARE\XAMPP
Registry Key : Install_Dir
Value : your_current_xampp_directory (E:\xampp in your case)

All you have to do is open the registry editor (start ---> run ---> type regedit then enter). Navigate to HKEY_LOCAL_MACHINE\SOFTWARE. Right-click on SOFTWARE and Choose New ---> Key. Then, type XAMPP then, click OK. Navigate to the XAMPP Key you just created, then right click on the right column (anywhere in the big white space) then again, New ---> String Value. Name it Install_Dir (probably case sensitive!) then hit Enter. Double click this value and in the appropriate box, type the path of your current XAMPP installation (E:\xampp in your case). Close the registry and restart the Control Panel and you're ready to start.


The reason for this is that 64bit versions of Windows do funky things with your registry. For example, all registry keys for 32-bit software are moved to a subfolder called 'Wow6432Node'. This means the registry key you need to edit is:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\XAMPP
Registry Key : Install_Dir
Value : your_current_xampp_directory (E:\xampp in your case)

The rest of the procedure is similar, but just use this registry key instead of the one described by Draven. Hope this helps.
akie43
 
Posts: 1
Joined: 16. April 2009 10:03

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby sandycollie » 09. May 2009 11:50

Hello All

I am new to this forum and this is my first post. I'm posting in this created thread because I have the same exact need.
sandycollie
 
Posts: 1
Joined: 09. May 2009 11:45

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby Sharley » 10. May 2009 03:31

sandycollie wrote:...I'm posting in this created thread because I have the same exact need.
Then if you read the previous posts you will find the solution, that is, if you are concerned about the Directory Mismatch message in the XAMPP Control Panel - if you can live with the message and most do, then there is no need to do anything at all, as the message is only informative and has no real effect on the running of XAMPP which doesn't add anything to the registry in a default installation.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby manola » 11. June 2009 09:49

the directory exist and is at the right place in the xampp directory
sonnerie portable gratuite
manola
 
Posts: 1
Joined: 11. June 2009 09:46

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby MzVikki » 14. June 2009 02:21

I'm having the same problem too; i trying to run a wordpress blog. I get the Directoy Mismatch warning message and if I run the localhost/wordpress/wp-admin.php. It gives me a Not found error message. I'm trying to run it on vista. Would there be something different with that particular operating system?
And where do I save the wordpress file?. . .in the xampplite or in htdocs folder?
When I save it in the htdocs folder it always gives me an "error with programming message".

could someone please please help
MzVikki
 
Posts: 1
Joined: 14. June 2009 02:03

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby ebflute » 19. July 2009 17:00

I have the directory mismatch message in my Xampp control panel. Everything works just fine (although I haven't installed any addons). I extracted the zip file and put the folder in the root of my C drive. It would be nice to have not have the directory mismatch message and I would like to follow the directions here to add xampp to the registry but I have 32 bit Vista, will it be the same instructions? I am running Vista 32 bit home premium and just downloaded version xampp 1.7.1.
ebflute
 
Posts: 1
Joined: 19. July 2009 16:48

Re: Warning : Directory mismatch when I lauch xampp-control.exe

Postby dracu » 04. August 2009 23:39

It's the same procedure.

However, I was getting the same message with directory mismatch, because I deleted the "logs" folder for apache, which are set up in the /apache/conf/extra/httpd-vhosts.conf file. I fixed the situation and everything works fine.
dracu
 
Posts: 1
Joined: 04. August 2009 23:35

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 47 guests