OMG security is annoying!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

OMG security is annoying!

Postby SirChick » 20. July 2007 13:15

I been applying a password to the Root and every time i do i get "invalid settings" and im locked out for good. So i have to keep re-installing it. Ive done this 7 times now!

It worked one time, but i re-installed because i messed up all the root document stuff and forgot to back up. Why wont it work. It succesfully changes the password... then decides never to work again.

I'm loosing my patience
SirChick
 
Posts: 68
Joined: 19. June 2007 15:03
Operating System: Windows 7 64 bit

Re: OMG security is annoying!

Postby Eric Pement » 21. July 2007 01:53

SirChick wrote:I been applying a password to the Root and every time i do i get "invalid settings" and im locked out for good. So i have to keep re-installing it. Ive done this 7 times now!

It worked one time, but i re-installed because i messed up all the root document stuff and forgot to back up. Why wont it work.

I assume that you mean the password to MySQL. Is that correct?

If MySQL is active, turn it off (on the XAMPP Control Panel Application, click the 'STOP' button to the right of the MySQL line). The green "RUNNING" bar should no longer appear.

Go to "c:/Program Files/xampp/mysql/bin/my.cnf" (or to whatever folder you installed XAMPP) and copy "my.cnf" to a backup filename in the same directory. Something like "my_old.cnf" is probably fine. Then edit "my.cnf" with a plain ASCII editor that will not add funny stuff to the file. (NoteTab, Metapad, UltraEdit, vim, Emacs, etc.)

Under the "[client]" descriptor, if "password" is prefixed by a "#" comment sign, uncomment that line and then put in your password. Start with a basic alphanumeric string, and if it works, you can make it more complex later. Save your changes. Save your password in an external file where you won't forget where you stored it. (I keep all my passwords in a master "password" file which is itself encrypted. I only need to know one password, and that gives me access to all the others.)

Then go back to the XAMPP Control Panel Application, refresh and restart the MySQL service.

I suppose that one should be able to go through http://localhost/security/index.php, but the method I describe above worked for me. Note that the username will still be "root" for MySQL.
Eric Pement - pemente [at] northpark [dot] edu
Eric Pement
 
Posts: 25
Joined: 19. May 2007 18:35

Postby ldivinag » 22. July 2007 12:41

mysql has a facility to recover, or start the daemon without passwords.

the trick is that you must be at the console to do this:

http://dev.mysql.com/doc/refman/5.0/en/ ... sions.html

btw, did you ever set the mysql password INITIALLY?

by default, the root account has no password...
leo d.
User avatar
ldivinag
 
Posts: 40
Joined: 19. April 2006 04:18

Postby SirChick » 22. July 2007 18:34

i set a password but it wont even allow me to log in any more cos i just get "invalid settings"
SirChick
 
Posts: 68
Joined: 19. June 2007 15:03
Operating System: Windows 7 64 bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 62 guests