Log is filling up with odd messages

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Log is filling up with odd messages

Postby RavenWebServices » 14. July 2007 12:34

I spent a while searching the forum for an answer but I could not find anything.

My log is filling up with the following messages. Does anyone know why and/or how to resolve it?

[Sat Jul 14 06:05:21 2007] [error] [client 192.168.0.118] no acceptable variant: C:/Program Files/xampp/apache/error/HTTP_NOT_FOUND.html.var
[Sat Jul 14 06:05:24 2007] [error] [client 192.168.0.118] File does not exist: C:/Program Files/xampp/htdocs/TEADevInfo
RavenWebServices
 
Posts: 2
Joined: 14. July 2007 12:13

Re: Log is filling up with odd messages

Postby Eric Pement » 21. July 2007 03:49

RavenWebServices wrote:My log is filling up with the following messages. Does anyone know why and/or how to resolve it?

[Sat Jul 14 06:05:21 2007] [error] [client 192.168.0.118] no acceptable variant: C:/Program Files/xampp/apache/error/HTTP_NOT_FOUND.html.var
[Sat Jul 14 06:05:24 2007] [error] [client 192.168.0.118] File does not exist: C:/Program Files/xampp/htdocs/TEADevInfo

Go to this page and look for the word "variant" and then narrow down to the error message, "no acceptable variant":

http://httpd.apache.org/docs/2.0/conten ... ation.html

Apparently you have a language directive that is not configured properly and Apache is unable to find an alternate language variant that is being requested.
Eric Pement - pemente [at] northpark [dot] edu
Eric Pement
 
Posts: 25
Joined: 19. May 2007 18:35

Postby RavenWebServices » 21. July 2007 05:26

I am using the virgin installation of XAMPP so it seems to be (possibly) a setup issue? In any event I modified conf/extra/httpd-manual.conf to show
Code: Select all
#
# Provide access to the documentation on your server as
#  http://yourserver.example.com/manual/
# The documentation is always available at
#  http://httpd.apache.org/docs/2.2/
#
# Required modules: mod_alias, mod_setenvif, mod_negotiation
#

AliasMatch ^/manual(?:/(?:de|en|es|fr|ja|ko|pt-br|ru))?(/.*)?$ "C:/Program Files/xampp/apache/manual$1"

<Directory "C:/Program Files/xampp/apache/manual">
    Options Indexes
    AllowOverride None
    Order allow,deny
    Allow from all

    <Files *.html>
        SetHandler type-map
    </Files>

   SetEnvIf Request_URI ^/manual/(de|en|es|fr|ja|ko|pt-br|ru)/ prefer-language=$1
   RedirectMatch 301 ^/manual(?:/(de|en|es|fr|ja|ko|pt-br|ru)){2,}(/.*)?$ /manual/$1$2

   LanguagePriority en de es fr ja ko pt-br ru
   ForceLanguagePriority Prefer Fallback
</Directory>

and that seems to have fixed all of the log errors. Thanks.
RavenWebServices
 
Posts: 2
Joined: 14. July 2007 12:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 30 guests