can't leave htdocs need some help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

can't leave htdocs need some help

Postby rcpalace » 12. July 2007 17:22

Hi guys, I have set up my xampp server and have added 3 domains for it.
I have done the needed in the apache httpd-vhosts file shown below:
Code: Select all
##<VirtualHost *:80>
##    ServerAdmin admin@cigaremp.com
##    <Directory "C:\xampp\htdocs\cigaremp.com">
##    ServerName cigaremp.com
##    ServerAlias www.cigaremp.com
##</Directory>
##</VirtualHost>

##<VirtualHost *:80>
##    ServerAdmin sales@rc-palace.com
##    <Directory "C:\xampp\htdocs\rc-palace.com">
##    ServerName rc-palace.com
##    ServerAlias www.rc-palace.com
##</Directory>
##</VirtualHost>

##<VirtualHost *:80>
##    ServerAdmin sales@dynno.com
##    <Directory "C:\xampp\htdocs\dynno.com">
##    ServerName dynno.com
##    ServerAlias www.dynno.com
##</Directory>
##</VirtualHost>


Yet, Instead of the domain checking the directory of it's own it only stays at the htdocs main file and not the directory for each domain.
What's going on?
Any help will be appreciated.
Kind Regards.
rcpalace
 
Posts: 9
Joined: 12. July 2007 17:15

Postby davidspan » 12. July 2007 20:06

XAMPP is one of the topics I write about
MyBlogIt!
davidspan
 
Posts: 47
Joined: 25. June 2007 01:59

Postby rcpalace » 12. July 2007 20:13

do I need xampplite? or xampp will work just fine?
Thanks.
rcpalace
 
Posts: 9
Joined: 12. July 2007 17:15

Postby davidspan » 12. July 2007 20:18

you can use xampp, just note the differences in the dir settings
XAMPP is one of the topics I write about
MyBlogIt!
davidspan
 
Posts: 47
Joined: 25. June 2007 01:59

Postby rcpalace » 12. July 2007 20:24

Alright thanks! it worked.
Kind regards.
rcpalace
 
Posts: 9
Joined: 12. July 2007 17:15

I got virtual hosts working but...

Postby Capt. Duck » 13. July 2007 10:15

I followed your steps above and got it working also but I have one other question.

I made the three following virtual host sites.
test
webdev
duck

However, when I point my browser to them it opens some default index file that is not in the virtual host site's dir
For example, if I point my browser to http://duck/
my browswer opens to http://duck/xampp/
and shows some default xampp file (two tone orange with "Welcome to XAMPP for Windows Version 1.6.2 ! and some links)
then, if I try to force it to the index.html file I created in that folder (http://duck/index.html) the URL in my browsers address bar remains as http://duck/index.html but the file that opens just says "IT WORKS".

Neither of the above are the index file the address points to, my index file say something different including what it's path is.

I don't know what setting is redirecting my browswer to open these xampp default index files.
Any help figuring out how to just let the virtual host sites open the index file in that sites home dir will be appreciated.

Thanks,
Capt. Duck
Capt. Duck
 
Posts: 2
Joined: 11. July 2007 18:00

Postby davidspan » 15. July 2007 00:52

remove the default files in the htdocs dir, leave the folders, just remove the files.
XAMPP is one of the topics I write about
MyBlogIt!
davidspan
 
Posts: 47
Joined: 25. June 2007 01:59

Postby Capt. Duck » 15. July 2007 03:57

davidspan wrote:remove the default files in the htdocs dir, leave the folders, just remove the files.


Thank you very much. I'll probably have more questions as I get into this.

"Duck"
Capt. Duck
 
Posts: 2
Joined: 11. July 2007 18:00

Postby jtp866 » 19. July 2007 11:56

jtp866
 
Posts: 6
Joined: 07. February 2006 23:00


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 58 guests