Help for a Newbie - Installed Mini XAMPP won't work!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help for a Newbie - Installed Mini XAMPP won't work!

Postby shawbapmp » 23. September 2003 21:53

Hi Apache Friends,

I successfully installed the Mini XAMPP version 1 for Windows XP, but the test pages don'w show up when I enter http://localhost in my browser. The message is the usual Page Not Found.

The installation instructions say something about opening port 80 for HTTP and 3128 for MySQL, but I don't know how to do that.

My proxy server settings have Address and Port fields, and the advanced settings show fields for HTTP, Secure, FTP and more. Is that where I'm supposed to tweak things? Or is there something else I am doing wrong?

Can someone advise me?
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 10:02

Dear Shawbapmp!

Please try instead of http://localhost the numeric variant http://127.0.0.1. Does it now work?

Greetings,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

No localhost or 127.0.0.1 page

Postby shawbapmp » 24. September 2003 13:55

Hi Oswald,

I tried both http://localhost and http://127.0.0.1 as the documentation says, but neither work.

It looks like some kind of configuration issue. A friend tried to install IIS on my machine and that too produced a Page Could Not be Displayed message with http://localhost in the URL.

Any suggestions?
Barry
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 16:54

Hi Barry!

Just for testing: Could you please disable your proxy settings and set your browser to direct network access. And than try it again.

Another trial: Try http://<IP address> of your XP machine.

Good luck! ;)
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Tried that - no luck

Postby shawbapmp » 24. September 2003 17:16

Hi Oswald,
Thanks for the quick reply.
My proxy server settings are off by default. I tried with the check box on and off.
I assume you are referring to the Internet Options box, Connections tab, LAN setting button, and Proxy Server check box for "Use proxy server for your LAN". Correct?
Barry
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 17:30

Hi Barry!

Correct! I'm a Linux user and I'm not familliar with the Windows terms. ;)

Okay, let's try the next point: Is the Apache actually runnig?

Get to the command prompt. Call now the command netstat -a. More or less many lines of output shoud appear. You should now see one line containing "<your host name>:http" in the second column. Do you see this line?

Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Apache test

Postby shawbapmp » 24. September 2003 17:45

Hi Oswald,
I first started the apache_start.bat file included in the downloaded package, which opened a cmd window saying Apache is starting...

Then I opened another cmd window and entered netstat, which generated an Active Connections list with D8xxxxxx:http on the first line, with State noted as Listening.

Is that a good sign?
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 18:07

Excellent! That's perfect! ;) The Apache is running and is waiting (listening) for web browsers.

Okay, another try:

Enter in a cmd window the following command:

telnet localhost 80

If the cmd window cleans you got connected to the Apache. In this case enter blindly (you can't see what you're typing) xxx and Enter. (You should now see some weird HTML code. Ignore it.)

But if the telnet command exits with an error message ("Connection refused" or something similar) something went totaly wrong with your system.

Okay.. like in a game show... What's happening? A or B?

Greetings,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Oh no - B happened

Postby shawbapmp » 24. September 2003 18:16

Oswald,
Sorry to keep you up. It must be pretty late in Berlin.

Option B happened. The last line in the command window was "connection to host lost".

How bad is that?
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 18:31

Hi Barry!

That's very bad! You can read it like this: Apache is running and accepting connection. But if he (she?) got a connection he drops it immediately! :(

I never saw such behaviour of the Apache under Window systems before. And now I'm a little bit helpless. :(

But don't let us give up. Can you please take a look into the error.log file? You should find it in the logs directory. Look at the end of this file. Do you find any error messages?

Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

The log says...

Postby shawbapmp » 24. September 2003 18:44

Oswald,
Instead of going through this message forum, you can contact me directly at barry.shaw@rogers.com.

The last line of the log file says client 127.0.0.1 Invalid method in request xxx. I forgot to mention that the first line in the cmd window after entering xxx says "The server does not support the action requested by the browser".

Barry
shawbapmp
 
Posts: 7
Joined: 23. September 2003 21:16
Location: Toronto, Canada

Postby Oswald » 24. September 2003 19:06

Let's mail...
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby Kristian Marcroft » 25. September 2003 11:03

Hi you 2... :)

But I think it would still be a good idea, to post the Answer here...
Thats what the Forum is for or not?

So please at least tell us what the problem was
I'd guess the XP Firewall oder some other Firewall or ViriScanner?

Thx
So long
KriS
User avatar
Kristian Marcroft
AF Moderator
 
Posts: 2962
Joined: 03. January 2003 12:08
Location: Diedorf

Postby Oswald » 25. September 2003 11:32

Hi KriS!

Of course we will post the solution here! If we get one! ;)

At the moment we found out that it seems to be a browser problem. Mozilla for example works. IE not. But we are still looking after the real cause...

Stay tuned.. ;)

Greetings,
Oswald
User avatar
Oswald
Apache Friends
 
Posts: 2718
Joined: 26. December 2002 19:51
Location: Berlin, Germany
XAMPP Version: 5.5.19
Operating System: Linux

Postby dejon » 12. October 2003 06:03

I just had what seemed to be the same problem - it went away after I unchecked "Automatically detect settings" in LAN settings for IE.
dejon
 

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests