MySQL busy

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL busy

Postby adaykin » 09. July 2007 04:49

Hey when I open up the XAMPP control panel and try and start the MySQL service it says:

Busy...
ERROR: MySQL service not started [-1]

I assume it is because the port MySQL is supposed to be running on is being used but I am not sure...any ideas?


Also I am not able to test my php files. I put them in C:\xampp\htdocs\nameOfMyFile.php, but when I point my web browser with apache running to http://localhost/nameOfMyFile.php I get an 404 error message saying object not found.
adaykin
 
Posts: 8
Joined: 08. July 2007 04:38

Postby adaykin » 19. July 2007 00:50

ok I put my php files in the C:\xampp\www folder now. When I go to my PHP pages I get a blank page that has absolutely nothing on it. The MySQL service is still saying:
ERROR: MySQL Service not started [-1]
adaykin
 
Posts: 8
Joined: 08. July 2007 04:38

Postby Eric Pement » 21. July 2007 02:58

adaykin wrote:ok I put my php files in the C:\xampp\www folder now.

I don't have a "www" folder in my XAMPP installation. When you open up your web browser and visit "http://localhost", it will actually try running "c:/xampp/htdocs/index.php" which will then redirect you to "c:/xampp/htdocs/xampp/index.php".

Did you create the new "www" folder beneath the /xampp/htdocs folder?

When I go to my PHP pages I get a blank page that has absolutely nothing on it. The MySQL service is still saying:
ERROR: MySQL Service not started [-1]

Try rewriting your PHP pages to produce at least a header or some output, regardless of whether MySQL is running. Try using "phpinfo()" to at least get some confirmation that PHP is active.
Eric Pement - pemente [at] northpark [dot] edu
Eric Pement
 
Posts: 25
Joined: 19. May 2007 18:35

Postby adaykin » 30. July 2007 05:45

ok I am able to get my web pages to display now...however I still can't get the database started. I typed the netstat -a command into the command prompt and for some reason port 3306 is not being displayed at all. When I try and start MySQL I still get the same message...Busy...MySQL service not started [-1].
adaykin
 
Posts: 8
Joined: 08. July 2007 04:38


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests