Mysql deactivated how do i activate it

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mysql deactivated how do i activate it

Postby infabmfy » 03. July 2007 17:25

Hi ive just installed XAMPP i ran the localhost. I clicked on the status tag and the status for Mysql is that it is deactivated how do I activate it. When i try to run mysql through DOS it says [ERROR] cant find messagefile 'c:\xampp\mysql\share\english\errmsg.sys' Aborting
and when i checked the folder the file is present what do i do?
Posts: 1
Joined: 03. July 2007 16:43

Postby ldivinag » 09. July 2007 10:46

mysql runs as a service in windows.

services are like daemons in the unix world.

you need to find out what the mysql service name is.

you can guess, like "mysql"

launch a dos window and type in:

Code: Select all
net start mysql

and see if returns with
Code: Select all
The service name is invalid.

More help is available by typing NET HELPMSG 2185.

then either xampp renames it or it's not running (i run my own install of mysql so i rename mine).

check the SERVICES control panel and see if mysql has already been installed as a service but has START MANUALLY... set it to start automatically... duh... ;)

if there is NO listing of mysql at all, just reinstall xampp or just install it by d/ling the latest version from

mysql can run independent from xampp. where as php needs apache, mysql doesnt care.
leo d.
User avatar
Posts: 40
Joined: 19. April 2006 04:18

Postby Everett » 01. August 2007 06:30

I installed Xampp on Win98se and cannot get it to work. When I open the control panel and click on Start for apache and mysql, a message comes up that says starting, but the panel never changes to the green running. When I go to localhost and check the status mysql is not running.

I have to shut down apache via DOS - can't do it with the control panel. Mysql never starts even though it say it does.

I tried starting mysql from DOS and get the message [ERROR] cant find messagefile 'c:\xampp\mysql\share\english\errmsg.sys' Aborting The path is correct and the file exists. I have double and triple checked the path names in the my.cnf file, php.ini file, tried setting the default dir when starting mysql from DOS - none worked.

I unistalled xampp and rebooted then reinstalled - same problem. So I uninstalled xampp and downloaded mysql from and got the same response [ERROR] cant find messagefile 'c:\xampp\mysql\share\english\errmsg.sys' Aborting .

Does mysql not work on Win98SE or what do I do to fix this problem? After three days of searching the forums here and at I am no closer to getting this solved and am about ready to give up.

Posts: 2
Joined: 01. August 2007 06:09

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 24 guests