phpMyAdmin - Error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin - Error

Postby globalmerchant » 02. July 2007 00:38

Hi,

I wondered if anyone has seen this kinda error before and knows how to go about fixing it.

After I install xampp on my windows vista, I go to http://localhost/xampp/index.php

Everytime I click on phpmyadmin, I get the following error:

Cannot load mysql extension. Please check your PHP configuration. - Documentation

I am ready to learn if someone can please point me in the right direction.

Thanks,
Mary.
globalmerchant
 
Posts: 6
Joined: 02. July 2007 00:31

Postby davidspan » 03. July 2007 05:57

In your httpd.conf
look for Loadmodule and add

extension=php_mssql.dll
extension=php_msql.dll
XAMPP is one of the topics I write about
MyBlogIt!
davidspan
 
Posts: 47
Joined: 25. June 2007 01:59

phpmyadmin error

Postby globalmerchant » 04. July 2007 01:38

Hi,

I went to:

C:\xampp\apache\config\httpd.conf

then, I found all the LoadModules Lines, and added

extension=php_mssql.dll
extension=php_msql.dll

after the last #loadmodules.

Then, I restart my computer.

When I open the control panel, the apache does not start.

If I don't restart the computer, I still get the error message.

If I remove the:
extension=php_mssql.dll
extension=php_msql.dll

from the httpd.conf, apache runs fine.

Thanks very much for helping. What can I do next?

Mary
globalmerchant
 
Posts: 6
Joined: 02. July 2007 00:31

Postby Buster2058 » 04. July 2007 05:08

davidspan wrote:In your httpd.conf
look for Loadmodule and add

extension=php_mssql.dll
extension=php_msql.dll


I think he meant to say look for those extension in your php.inifile.

php.ini is Usually found in "?:\xampp\apache\bin" folder.

Don't forget to restart apache after any config changes.
Buster2058
 
Posts: 2
Joined: 04. July 2007 05:01

error still exist

Postby globalmerchant » 04. July 2007 16:05

I saw in my php.ini file that one of those options was enabled. So, I enabled the other extension, restarted my computer, restarted apache, clicked on admin, clicked on myphpadmin link and observed that I still get the error message.

Thanks so much for wanting to help.

Mary.
globalmerchant
 
Posts: 6
Joined: 02. July 2007 00:31

Postby Buster2058 » 04. July 2007 18:29

In the admin click on the phpinfo() link and make sure that your editing the correct php.ini file that apache/php is loading.

ie: "Loaded Configuration File C:\xampp\apache\bin\php.ini"

I forgot what else needs to be done but I do remember that I also needed the "extension=php_mcrypt.dll" turned on, but that was after I was able to log into phpmyadmin.
Buster2058
 
Posts: 2
Joined: 04. July 2007 05:01

may be some hope here

Postby globalmerchant » 04. July 2007 19:33

hi,

thanks again and I appreciate your help. When I clicked on phpinfo(), the php.ini that was uploaded is located at C:\prgoram files\PHP\php.ini.

When I enable those variables and try to save, I get the following messages:

"cannot create the C:\Program Files\PHP\php.ini file. Make sure the path and file name are correct.

mary.
globalmerchant
 
Posts: 6
Joined: 02. July 2007 00:31

may be some hope here

Postby globalmerchant » 04. July 2007 19:33

hi,

thanks again and I appreciate your help. When I clicked on phpinfo(), the php.ini that was uploaded is located at C:\prgoram files\PHP\php.ini.

When I enable those variables and try to save, I get the following messages:

"cannot create the C:\Program Files\PHP\php.ini file. Make sure the path and file name are correct.

mary.
globalmerchant
 
Posts: 6
Joined: 02. July 2007 00:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests