xampp setup - php not recognized?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

xampp setup - php not recognized?

Postby jaybart » 26. June 2007 17:58

installed xampp, started apache server, it seems to be accessing files from C:\Inetpub\wwwroot... so I add a test.php file in there and attempt to access it - firefox prompts me to download the file... why is PHP not running?

Also, why is it starting at C:\Inetpub\wwwroot and not C:\xampp\htdocs?

Thanks
jaybart
 
Posts: 2
Joined: 26. June 2007 17:54

Postby Wiedmann » 26. June 2007 18:51

Also, why is it starting at C:\Inetpub\wwwroot and not C:\xampp\htdocs?

Because Apache from XAMPP is not running.
(The current running webserver must be IIS with this Documentroot)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jaybart » 26. June 2007 18:58

I don't quite understand, the document root is set to C:\xampp\htdocs in the httpd.conf file, and I am starting Apache via XAMPP Control Panel. So how could Apache from XAMPP not be running?

Thanks, appreciate the help
jaybart
 
Posts: 2
Joined: 26. June 2007 17:54

Postby Wiedmann » 26. June 2007 19:12

and I am starting Apache

Really, you have verified this with e.g. "xampp_portcheck.exe" or the task manager?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby kschroeder » 27. June 2007 06:44

Andy please check your services, I suppose there's still running the IIS service. You have to stop this service and prevent it being started automatically.
kschroeder
 
Posts: 254
Joined: 11. May 2007 13:33


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests