cant access webserver

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cant access webserver

Postby thongsai » 21. June 2007 04:46

each time i type local host or 127.0.0.1 it goes into the admin page of the xampp.

any suggestions?
thongsai
 
Posts: 1
Joined: 21. June 2007 04:39

Postby Wiedmann » 21. June 2007 09:33

What want you see instead?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Rhodesia » 24. June 2007 23:32

Three options,;

Browse to the index.php file in the htdocs folder and rename it redirect.php, then place your own index.php or index.htm page into that folder and viola you now dont see the xampp index page. (This way, if you want to get to the xampp folder, type in localhost/redirect.php and it will load the xampp page)

Or

Delete the files in the htdocs/xampp directory and start placing your own files into there. (you will no longer have access to the xampp page files or security files) but the rest of the server will function fine

Or

Change the httpd.conf (located in the apache\conf folder) file to set the root folder for the server, change the line
DocumentRoot "D:/program files/xampp/htdocs/"
to
DocumentRoot "D:/path/to/webfiles"
(obviously, the path/to/webfiles would need to reflect the location of the folder, something like C:\Documents and Settings\youraccount\My Documents\sitefolder\ where youraccount is your username and sitefolder is the folder you have the website files in)

Then in the httpd.conf file, change
Code: Select all
<Directory "D:/program files/xampp/htdocs/">
to the same location of the new folder you set above.

restart the apache server.
User avatar
Rhodesia
 
Posts: 13
Joined: 31. May 2006 05:02


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests