Input data not being stored on MySQL via localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Input data not being stored on MySQL via localhost

Postby Cassidy » 14. June 2007 11:44

I have searched this forum (and others) trying to find anyone who has had similar problems to mine mentioned below, and from the results, I have tried all the recommended changes, etc, but to no avail. So hopefully someone out there can assist.

I have installed Xammp (latest) on Windows XP Home (SP2), and the demo pages all work fine - no errors noted. But other strange things are noted as follows-

Issue 1.
When browsing //localhost, my "make connection to Internet" window pops up. While this "window" is present, I cannot browse through any localhost links (ie PhpMyAdmin, etc), until I either Cancel the link request or Connect to the Internet. If I select Cancel, I can continue browsing through localhost links until the windows pops up again (approx every 5 minutes). If I do Connect, then all appears fine. I normally use Firefox for //localhost as IE 7 states it cannot find server unless a connection to the Internet is present.
Does anyone have an idea as to why the connection window is poping up continually and why IE7 cannot find //localhost unless an Internet Connection is active?

Issue 2.
I have a small piece of test code - a form in html that calls a php page, a basic registration type script, the point being to store member details.
I have uploaded these pages to my ISP Web Host and the pages work fine through an Internet connection, the data is stored on MySQL, etc, etc. But when I run the same pages locally, the php page behaves differently, as follows -
a - using IE 7, the html leg displays and when submiting, the php page is displayed as the full php code, and no data written to MySQL.
b - using Firefox, the html leg displays and when submitting, only the "next" link on the php page is displayed (correctly), but no data is written to MySQL.
In both cases no Error messages are displayed.
My Web Host is also running Php with MySQL.
If anyone out there knows how I can resolve the local issue I would really appreciate it.
Cassidy
 
Posts: 4
Joined: 14. June 2007 11:07

Issue 2 has been solved

Postby Cassidy » 20. June 2007 09:57

Resolved Issue 2
Cassidy
 
Posts: 4
Joined: 14. June 2007 11:07

Re: Input data not being stored on MySQL via localhost

Postby lyntuan » 25. June 2007 00:29

Cassidy wrote:Issue 1.
When browsing //localhost, my "make connection to Internet" window pops up. While this "window" is present, I cannot browse through any localhost links (ie PhpMyAdmin, etc), until I either Cancel the link request or Connect to the Internet. If I select Cancel, I can continue browsing through localhost links until the windows pops up again (approx every 5 minutes). If I do Connect, then all appears fine. I normally use Firefox for //localhost as IE 7 states it cannot find server unless a connection to the Internet is present.
Does anyone have an idea as to why the connection window is poping up continually and why IE7 cannot find //localhost unless an Internet Connection is active?

Add to C:\Windows\system32\drivers\etc\hosts this line:
127.0.0.1 localhost

(Create file named hosts if it does not exist)
Last edited by lyntuan on 26. December 2008 13:34, edited 1 time in total.
lyntuan
 
Posts: 104
Joined: 08. November 2006 00:21

Postby Cassidy » 26. June 2007 15:18

Cheers for the feedback lyntuam - really appreciated. However, when checking, the file does exist with the correct details. Any other possible suggestions?
Cassidy
 
Posts: 4
Joined: 14. June 2007 11:07


Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 69 guests