MySQL - cannot load <mcrypt> extension

Problems with the Windows version of XAMPP, questions, comments, and anything related.

MySQL - cannot load <mcrypt> extension

Postby johngoodman » 04. June 2007 15:42

I get the following error when logging into MySQL. I used the windows installer:

xampp-win32-1.6.2-installer.exe

ERROR MSG:

Cannot load mcrypt extension. Please check your PHP configuration.

Any ideas?
johngoodman
 
Posts: 6
Joined: 12. August 2005 08:25

Postby Codesmith » 04. June 2007 16:32

Did you do anything else other than run the installer?

Is this the only version of apache installed on your system?
Codesmith
 
Posts: 101
Joined: 31. March 2007 21:11

Cannot load mcrypt extension. Please check your PHP configur

Postby rowbearto » 14. June 2007 01:46

I also get this error. I found a way to get rid of it from a comment in this forum: http://us2.php.net/mcrypt . I don't know if it is the best way to fix the problem however. I would appreciate feedback on this issue.

The only thing that I changed after the xampp install (this is for version 1.6.1) was that I went to the security page and created a login for phpMyAdmin using "cookie" based authentification. Before creating that password, I didn't get the mcrypt error in phpMyAdmin, but it did complain about me not having a password. After creating the password, when I go to phpMyAdmin, I get the error.

This is the only version of Apache installed on my system.

The comment from the above website which fixed my problem was this:

To enable mcrypt extension under Windows you need to:
1) uncomment line "extension=php_mcrypt.dll" in php.ini
2) download libmcrypt.dll from http://files.edin.dk/php/win32/mcrypt/ and put it to System32 directory (for example C:\Windows\System32).
Tested on Windows XP+Apache 1.3.37+PHP 4.4.6 (as SAPI module!!!)

P.S.
I wrote this because I got "Cannot load mcrypt extension. Please check your PHP configuration." from phpMyAdmin when I simply uncommented "extension=php_mcrypt.dll" line.


Rob
http://robsnotebook.com
rowbearto
 
Posts: 8
Joined: 14. June 2007 01:33

Re: Cannot load mcrypt extension. Please check your PHP conf

Postby SKv » 14. June 2007 17:11

rowbearto wrote:I also get this error. I found a way to get rid of it from a comment in this forum: http://us2.php.net/mcrypt . I don't know if it is the best way to fix the problem however. I would appreciate feedback on this issue.

All that I did was to uncomment mentioned line in php.ini
php_mcrypt.dll is coming by default and it is placed in xampp\php\ext by defaul.
I have to admit that I didn't used installer but zip files.
SKv
 
Posts: 4
Joined: 14. June 2007 17:05

Worked for me too

Postby rowbearto » 16. June 2007 18:39

Based on your message, I just uncommented the line in php.ini and did not copy over the .dll from the website (actually, since I already had it, I deleted it).

This worked fine.

And I used the installer, so it works for that too.

I checked the directory that you mentioned, and indeed the right .dll file was there.
rowbearto
 
Posts: 8
Joined: 14. June 2007 01:33

Thanks

Postby rowbearto » 16. June 2007 18:41

I forgot to say Thank you, so Thank You.
rowbearto
 
Posts: 8
Joined: 14. June 2007 01:33

Re: Thanks

Postby SKv » 16. June 2007 23:15

rowbearto wrote:I forgot to say Thank you, so Thank You.
LOL! You are most welcome! :)
SKv
 
Posts: 4
Joined: 14. June 2007 17:05

Postby raid2005 » 07. July 2007 19:12

Mine is different, I setup complex installation, separate from the package,

I installed first from php, apache, mysql. now in my phpMyAdmin, I stop the apache and uncomment the said extension through php.ini:

extension=php_mbstring.dll
extension=php_mcrypt.dll

then restart the apache.

the php_mbstring worked but the php_mcrypt @ phpMyAdmin didn't.

Any other clue?
raid2005
 
Posts: 2
Joined: 07. July 2007 19:04

Postby SKv » 08. July 2007 23:23

raid2005 wrote:Mine is different, I setup complex installation, separate from the package
I have no idea what you did but it sounds as if your extension directory is not in the system path.
Dirty solution would be one mentioned above to copy libmcrypt.dll to system32 folder but that would make any future updates a nightmare. If you by any chance would like to do it properly you should put extension extension directory to the system path. You can find how to do it on apache.org
Off course the best option is to forget about "complex installation" and use package but I guess that you have good reasons why you didn't do it at the first place. :)
SKv
 
Posts: 4
Joined: 14. June 2007 17:05

Postby raid2005 » 10. July 2007 09:45

SKv wrote:
raid2005 wrote:Mine is different, I setup complex installation, separate from the package
I have no idea what you did but it sounds as if your extension directory is not in the system path.
Dirty solution would be one mentioned above to copy libmcrypt.dll to system32 folder but that would make any future updates a nightmare. If you by any chance would like to do it properly you should put extension extension directory to the system path. You can find how to do it on apache.org
Off course the best option is to forget about "complex installation" and use package but I guess that you have good reasons why you didn't do it at the first place. :)


problem solved... thanks
raid2005
 
Posts: 2
Joined: 07. July 2007 19:04

Postby SKv » 10. July 2007 15:31

raid2005 wrote:problem solved... thanks

You are welcome if it was I who helped you. Otherwise it would be great if you could let us (community) know how you solved the problem.
Ciao,
Goran
SKv
 
Posts: 4
Joined: 14. June 2007 17:05


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests