Subdomain Nameserver Troubles

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Subdomain Nameserver Troubles

Postby xTerminus » 31. May 2007 23:55

Hi,

I have searched the forums & am not finding the specific information I seek. Perhaps someone knowledgable on this setup can help me out.

The problem I'm having is that my domains will only work when I set each individual A record directly to my IP, but what I want to do is run through my subdomain nameservers which have the A record set to my IP (ns1.example.us/ns2.example.us).

My httpd-vhosts.conf file seems to function correctly.
Here's an example (I've obscured my actual domains):

NameVirtualHost *:80

<VirtualHost *:80>
ServerName example.us
ServerAlias www.example.us
DocumentRoot "X:/HTDOCS/example.us"
</VirtualHost>

<VirtualHost *:80>
ServerName example2.com
ServerAlias www.example2.com
DocumentRoot "X:/HTDOCS/example2.com"
</VirtualHost>

<VirtualHost *:80>
ServerName example3.com
ServerAlias www.example3.com
DocumentRoot "X:/HTDOCS/example3.com"
</VirtualHost>

etc..

My domain registrar gives me full DNS control so there's no problems there.

To reiterate, if I set an individual domain's A record directly to the server IP, everything works fine, but using nameservers ns1.example.us/ns2.example.us will not work, even though they have the correct A records. Everything is resolving as it should, but the server just won't serve the websites when using the subdomain nameservers, only when directly setting the IP of a domain's A record.

I suspect this might have something to do with BIND, but I'm not certain & can't seem to find any reliable information regarding the subject. Do I have to actually run a DNS/BIND server in order to use the nameservers effectively, even though the internet already resolves these nameservers correctly? Or is there something else I need in the VirtualHost containers to get the domains to work with the nameservers? I don't simply want to create VirtualHosts for the subdomains ns1.example.us/ns2.example.us, as these are not actual sites/destinations, but maybe there is some other VirtualHost coding I need to be able to use the subdomains as nameservers for the actual domains?

Any help or advice would be much appreciated.

Thanks,
-x

Edit - Simplified/clarified the issue a little better.
xTerminus
 
Posts: 1
Joined: 31. May 2007 21:39

Return to XAMPP for Windows

Who is online

Users browsing this forum: hthnightwolf and 68 guests