older version of Apache needed

Problems with the Windows version of XAMPP, questions, comments, and anything related.

older version of Apache needed

Postby afterdark » 14. May 2007 22:04

Please could some kind soul point me to the version of XAMPP that last used version 2.0 of Apache as I need 2.0 to run with SubVersioN.

Many thanks.
afterdark
 
Posts: 4
Joined: 14. May 2007 21:59

Postby Wiedmann » 14. May 2007 22:17

Apache as I need 2.0 to run with SubVersioN.

And why want you not use Apache 2.2 with Subversion?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby afterdark » 14. May 2007 22:30

Thank you for your reply.
The release of Subversion for windows I'm using is built against Apache 2.0
Note that the Apache modules included in this package was compiled against Apache HTTP Server 2.0, and thus will not work with Apache HTTP Server 2.2.

Quote from
Subversion Project

So knowing which older version contains v2.0 would be most helpful

Thanks again
afterdark
 
Posts: 4
Joined: 14. May 2007 21:59

Postby Wiedmann » 14. May 2007 22:37

The release of Subversion for windows I'm using is built against Apache 2.0

I think it's better to use a subversion release, which is build against Apache 2.2 instead of using an old Apache.

(This build is also available at tigris.org)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby afterdark » 14. May 2007 23:02

Thanks for the fast reply
Unfortunately I don't have that option, as that part of the project is not under my control, and the person in charge of the SVN setup isn't being at all helpful to my needs :roll: So I have to fit around the existing system.

I would like to use 2.2 but just cant, hence needing an older version of XAMPP.
afterdark
 
Posts: 4
Joined: 14. May 2007 21:59

Postby Wiedmann » 14. May 2007 23:36

Unfortunately I don't have that option, as that part of the project is not under my control,

I don't understand that... if you can install a specific XAMPP version, you must also have the rights to copy the correct subversion dlls to the XAMPP directory?

BTW:
IMHO XAMPP 1.6.1 comes with all necessary files. You must only enable/configure this extension. And there is no difference in configuring/using Subversion with Apache 2.0 or 2.2...

BTW:
The last XAMPP with Apache2.0 (and an old MySQL/PHP/...) was version 1.5.0-pl1.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby afterdark » 15. May 2007 00:12

I am part of a group project and am in charge of getting a website up and running, my colleague is in charge of version control.

As he had already set the SVN up months ago he is being difficult about modifying it in any way.

As I said I would like to use XAMPP 1.6.1 but he is being an arschloch ;)
afterdark
 
Posts: 4
Joined: 14. May 2007 21:59


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests