PHP CLI crashing on Vista

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP CLI crashing on Vista

Postby jrhoades » 13. May 2007 18:38

Hi,

I am using xampp 1.6.1 on Windows Vista Ultimate.

Every time I use the PHP CLI it performs the task but then the cmd windows freezes and a windows 'php cli has stopped responding' box appears. I then close this box (using the red cross rather than terminating the application) and I can carry on as if nothing has happened!

Although it is possible to use the cli, it is very annoying. I can only guess that the php cli is appearing to crash to windows, but not actually crashing.

(Typically I am running PEAR commands eg pear upgrade-all and I have UAC turned off)

Any help greatly appreciated.

Regards Jon
jrhoades
 
Posts: 3
Joined: 13. May 2007 18:31

Postby Wiedmann » 13. May 2007 19:01

1st. I don't know anything about PHP-CLI on Vista (or Vista itself).

Typically I am running PEAR commands eg pear upgrade-all and I have UAC turned off

The PEAR command line tool is not really usable in XAMPP.
If you need and work with PEAR, I can only recommend to delete the one from XAMPP and make a clean PEAR installation.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Wiedmann » 13. May 2007 19:08

One additional question:
Every time I use the PHP CLI

- How did you use the CLI?
- What happens if you open a command shell, "cd" to the php directory and execute "php -n -i"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jrhoades » 13. May 2007 19:18

Hi,

Thanks for the advice about PEAR, I have now installed it direct, but I'm still getting the crash dialog - for instance I got when doing "php go-pear.bat", so I am pretty sure it's a PHP CLI issue.

Regards Jon
jrhoades
 
Posts: 3
Joined: 13. May 2007 18:31

Postby Wiedmann » 13. May 2007 19:21

What's about my other question?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jrhoades » 13. May 2007 19:44

hi,

Sorry missed your other question - 'php -n -i' did also end up crashing.

I managed to fix the problem by downloading from php.net, the latest zip of PHP and copying over the PHP & EXT directories. It appears that PHP 5.2.2 (rather than xampp's 5.2.1) includes : "Fixed commandline handling for CLI and CGI."

Thanks for your help (and amazingly quick response!)

Reagards Jon
jrhoades
 
Posts: 3
Joined: 13. May 2007 18:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 66 guests