Page 1 of 1

XAMPP on Vista

PostPosted: 04. May 2007 16:59
by DavidS

I've just bought a HP laptop with Windows Vista Premium.
After I downloaded the zip-file for Xampp and installed it, I couldn't get Apache to start because it was set to "busy". I tested starting Apache from the control panel and from the apache-folder, but it didn't work.

Notable: MySQL is working real great and I've disabled the "user access control"-crap :P

I didn't set mysql/apache/mozilla as service when installing xampp.

Thank you!

PostPosted: 04. May 2007 17:42
by DavidS
The problem is solved.

a) I disabled the UAC
b) My PC is originally English, but my Vista is Norwegian, so I installed xampp in the following location:
c:\programfiler\xampp instead of c:\program files\xampp (I think Vista uses them both together as one folder, so it's really up to me what I choose). This was not working. When I tried to start apache from "apache_start.exe", I got some syntax errors. So, I restarted my computer (which I didn't do after disableing the UAC..) and installed xampp again (now just in c:\xampp) and that worked!

Apache loaded successfully!!

(Hope you did understand my lovely English :roll: )


PostPosted: 06. May 2007 21:08
by Arleinne
I try new version about XAMPP on VISTA StarterPack and Vista Premium 30days, and it's work (I usually using apache and mysql service only). may I suggest you to using the latest XAMPP, because I have same trouble with you when I using earlier version of XAMPP.

perhaps can help you ^_^

PostPosted: 08. May 2007 14:20
by Draxyl
I also had the same problem with Apache not starting on Vista.
In my case, this was due to both Skype and Apache using Port 80.
Once the port in Skype was changed, Apache started up ok.
Skype -> Tools -> Options -> Connection: Disable "Use Port 80 and 443 as alternatives for incoming connections".