zend optimizor urgent help needed pls

Problems with the Windows version of XAMPP, questions, comments, and anything related.

zend optimizor urgent help needed pls

Postby jesi1801 » 03. May 2007 01:15

Hi, I have to develop custom templates for a script that has been encoded in zend and ioncube
I tried to installed manually all the stuffs (apache,php,sql,zend) but it never worked i searched on various forum posted everywhere i couldn't get the solution
i tried to work with ioncube also but it doesn't work too
finally i came to install xampp but the zend optimizor again doesn't works everything is correct and set properly but it doesn't works please someone help me on this issue i need urget help
below is my php.ini configuration for zend optimizor

Code: Select all
[Zend]
zend_extension_ts = "D:\server\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "D:\server\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =


the phpinfo(); doesn't even shows that i zend optimizor is installed
btw i m using windows xp
jesi1801
 
Posts: 4
Joined: 03. May 2007 01:08

Postby Wiedmann » 03. May 2007 01:58

below is my php.ini configuration for zend optimizor

This is the "php.ini" from XAMPP and PHP uses this "php.ini"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jesi1801 » 03. May 2007 02:20

wt do u mean by that i don't get it
btw i have upgraded to latest version of xampp it shows that i have zend optimizer installed
with Zend Optimizer v3.2.4, Copyright (c) 1998-2007, by Zend Technologies


but still while i try to run a zend coded script it says that it needs zend optimizer not intalled
please help :cry:
jesi1801
 
Posts: 4
Joined: 03. May 2007 01:08

Postby Wiedmann » 03. May 2007 03:11

btw i have upgraded to latest version of xampp it shows that i have zend optimizer installed

With a fresh XAMPP installation you must enable the Loader in "php.ini", before you can execute Zend encoded PHP scripts.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jesi1801 » 03. May 2007 03:19

i have enabled the loaders i have set the value to 1 but still i can't run the script


it is like this

Code: Select all
[Zend]
zend_extension_ts = "C:\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "C:\xampp\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 1
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =
; Local Variables:
; tab-width: 4
; End:
jesi1801
 
Posts: 4
Joined: 03. May 2007 01:08

Postby Wiedmann » 03. May 2007 11:26

Code: Select all
zend_optimizer.enable_loader = 1

You can verify this setting in "phpinfo()"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jesi1801 » 03. May 2007 14:04

thanx alot Wiedmann,
i figure out the main problem i edited the php.ini file but that thas inside the php/ directory but i should have edit the fine inside apache directory
thanx a lot again it would have been very tough without your help
regards
jesi1801
 
Posts: 4
Joined: 03. May 2007 01:08


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests