Problem Running XAMPP from iPod

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Problem Running XAMPP from iPod

Postby sean_mcgee » 02. May 2007 17:51

I set up XAMPP on my iPod to run a web app.

The web app requries InnoDB to be enabled in MySQL.

I uncommented the section of the MySQL file.

However, it gives me an "operating system error 87".
MySQL.com said: 87 (ERROR_INVALID_PARAMETER)

The parameter is incorrect. (If this error occurs on Windows and you have enabled innodb_file_per_table in a server option file, add the line innodb_flush_method=unbuffered to the file as well.)


I did not enable innodb_file_per_table, however, I added the line it suggested anyways. Unfortunately that didn't change things.

I don't get this error when I use a USB stick, only with an iPod (Nano 2 Gen).

Is there a conflict with the iPod or is there another setting I can change?

EDIT:

Here is the exact text from the cmd window when the error occurs:

070502 12:14:25 InnoDB: Operating system error number 87 in a file operation.
InnoDB: Some operating system error numbers are described at
InnoDB: http://dev.mysql.com/doc/refman/5.0/en/ ... codes.html

InnoDB: File name \xampplite\mysql\data\ib_logfile0
InnoDB: File operation call: 'aio write'.
InnoDB: Cannot continue Operation
sean_mcgee
 
Posts: 2
Joined: 02. May 2007 17:43
Location: San Antonio, TX

Postby sean_mcgee » 03. May 2007 14:36

Wow...I guessed I stumped everyone.
sean_mcgee
 
Posts: 2
Joined: 02. May 2007 17:43
Location: San Antonio, TX


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests