Apache crashing

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache crashing

Postby chris48178 » 01. May 2007 03:03

Everyother day or so, I have been getting 404 error when trying to view my site hosted on a local server running XAMPP. When I log on to the server I see the following error message:

Code: Select all
apache.exe Application Error

The Instruction at "0x0096ae66" referenced memory at "0x020f6000" the memory could not be "read".


It appers to coincide with the following application event log:

Code: Select all
Event Type:   Error
Event Source:   Application Error
Event Category:   (100)
Event ID:   1000
Date:      4/30/2007
Time:      10:11:48 AM
User:      N/A
Computer:   SERVER
Description:
Faulting application apache.exe, version 2.2.3.0, faulting module php5ts.dll, version 5.2.1.1, fault address 0x000b3194.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 61 70 61   ure  apa
0018: 63 68 65 2e 65 78 65 20   che.exe
0020: 32 2e 32 2e 33 2e 30 20   2.2.3.0
0028: 69 6e 20 70 68 70 35 74   in php5t
0030: 73 2e 64 6c 6c 20 35 2e   s.dll 5.
0038: 32 2e 31 2e 31 20 61 74   2.1.1 at
0040: 20 6f 66 66 73 65 74 20    offset
0048: 30 30 30 62 33 31 39 34   000b3194


Any ideas on where to start troubleshooting?
chris48178
 
Posts: 1
Joined: 01. May 2007 02:48

Re: Apache crashing

Postby Shailen Sobhee » 05. March 2008 14:08

Hello,

I managed to correct the bug here. I happened to have SoftICE debugger running in the background. So, ensure you don't have a system debugger running at your place too.

Also try to disable some database services at startup, and if you have IIS or any other webserving services, disable them. Restart your machine and start Apache first. Then start the other services you stopped. If that worked, google a good way to start Apache before any other service. Good luck. Hope that helps!

I read that skype had an issue with Apache as well. Try to disable momentarily any communication software (MSN,skype, gtalk, etc..)

Come back if it doesn't, we shall try another thing together.

Email : ai [dot] revolutions [at] gmail [dot] com

Shailen Sobhee
Mauritius
http://digitalgraphy.wordpress.com
by Shailen Sobhee
Mauritius
ai [dot] revolutions [at] gmail [dot] com
Shailen Sobhee
 
Posts: 1
Joined: 05. March 2008 14:05
Location: Mauritius


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests