PHP MyAdmin --> 1045 - Access denied for user 'pma'@'loca

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP MyAdmin --> 1045 - Access denied for user 'pma'@'loca

Postby madoc » 26. April 2007 10:56

Hi there..

I'm having a bit of trouble adding a database to my local web server.

When I access phpAdmin under tools on the startpage (http://localhost/xampp/) an error message shows...


--------------------------------------
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in config.inc.php and make sure that they correspond to the information given by the administrator of the MySQL server.

ERROR

MySQL said: Documentation
#1045 - Access denied for user 'pma'@'localhost' (using password: NO)
--------------------------------------

It looks like my password is wrong, but when i go to the config.inc.php and look for username and password they are root\\' ' and that should be the right ones...

thnx for any help guys :)

from:
Morten Rønning
madoc
 
Posts: 2
Joined: 26. April 2007 10:50

Postby Wiedmann » 26. April 2007 11:21

and look for username and password they are root\\' '

Look at the error message:
madoc wrote:Access denied for user 'pma'@'localhost'

The passwort for the user "pma" is not correct in "config.inc.php" (according to the setting in the MySQL server).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby madoc » 26. April 2007 11:27

haha... jiz! yea it worked now.. changed user to pma....

thnx alot :D
madoc
 
Posts: 2
Joined: 26. April 2007 10:50

Postby Thomasmore » 17. July 2007 00:54

madoc wrote:haha... jiz! yea it worked now.. changed user to pma....

thnx alot :D


I'm having the same problem. How did you fix it? Everything is default and I haven't changed anything yet.
Thomasmore
 
Posts: 1
Joined: 17. July 2007 00:45

Postby delftdamage » 17. July 2007 08:15

Thomasmore wrote:I'm having the same problem. How did you fix it? Everything is default and I haven't changed anything yet.


Are you joking or just stupid?
You reply a question on the answer :)
delftdamage
 
Posts: 30
Joined: 15. June 2007 23:56

Postby jtp866 » 19. July 2007 11:49

the server rejected the connection


this means mysql is not running. you need both apache and mysql running to access phpmyadmin
jtp866
 
Posts: 6
Joined: 07. February 2006 23:00


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests