Can't get Xdebug to work with XAMPP lite

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't get Xdebug to work with XAMPP lite

Postby steve0406 » 20. April 2007 18:24

I've successfully installed XAMPP lite, run some php scripts and accessed a MySQL database.

However I can't get Xdebug to work. I've downloaded the Win binary for PHP5.2.1, added 'zend_extension_ts=path to xedebug.dll' to php.ini and commented out 'extension=php_xdebug.dll and disabled all other Zend extensions

When I run phpinfo() Xdebug doesn't appear.

Is Xdebug compatible with XAMPP lite for Windows?

If anyone has got it to work, could they explain how?
steve0406
 
Posts: 6
Joined: 20. April 2007 18:10

Postby Wiedmann » 20. April 2007 19:10

Wrong "php.ini"?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steve0406 » 20. April 2007 19:29

Wow, thank you for the quick reply :-)

I edited the php.ini file shown by phpinfo() which is located in apache/bin/ I think thats the right one?
steve0406
 
Posts: 6
Joined: 20. April 2007 18:10

Postby Wiedmann » 20. April 2007 20:12

I edited the php.ini file shown by phpinfo()

That's the correct one.

BTW:
added 'zend_extension_ts=path to xedebug.dll' to php.ini and commented out 'extension=php_xdebug.dll and disabled all other Zend extensions

What are you doing exactly?

To load this extension you must only disable the Zend Optimizer:
Code: Select all
;zend_extension_ts = "\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"

(add the ";")

And add this line:
Code: Select all
zend_extension_ts = "\xampp\php\ext\php_xdebug.dll"

(if you have put the dll with this name into the directory "\xampp\php\ext")
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby steve0406 » 21. April 2007 10:30

Thank you I got it working.

For anyone else who has the same problem, change the following lines in I:\xampplite\apache\bin\php.ini to:-

;extension=php_xdebug.dll

;zend_extension_ts = "I:\xampplite\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts = "I:\xampplite\php\zendOptimizer\lib\Optimizer"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
zend_optimizer.license_path =

Put the Xdebug dll in I:\xampplite\php\ext\, making sure you download the right one for your version of php!

Add to the bottom of php.ini :

zend_extension_ts = "I:\xampplite\php\ext\php_xdebug.dll"

Save php.ini restart Apache and run phpinfo() next to the Zend2 logo it should now say Xdebug, further down you should see a panel showing the Xdebug settings.

You are now ready to start debugging!

Added: I use the drive letter I, you will need to change this to suit your setup.
steve0406
 
Posts: 6
Joined: 20. April 2007 18:10


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 41 guests