safe_mode

Problems with the Windows version of XAMPP, questions, comments, and anything related.

safe_mode

Postby thedoc420 » 10. April 2007 00:46

sorry to make another post about this but i didnt understand any of the other 2 that i found in english. i am a total noob at this. so i followed the other guide where it said to set these variables as so:
safe_mode = On
register_globals = Off


so i did that and restarted apache... still nothing...

UPDATE: ok so now i got it to work for some odd reason it just started working, but now when i try to install oscommerce it tells me this error message:

FATAL ERROR: register_globals is disabled in php.ini, please enable it!


so i went and turned register globals on and i still get that error...

here is a link: http://factions.servegame.com/order/install/
php.ini: http://factions.servegame.com/php.ini
thedoc420
 
Posts: 3
Joined: 10. April 2007 00:42

Postby Codesmith » 10. April 2007 02:30

This really isn't an XAMMP question, its a question about how to setup oscommerce.

Maybe someone here will know the answer, but you get much better results when you address the question to the right forum.

http://forums.oscommerce.com/
Codesmith
 
Posts: 101
Joined: 31. March 2007 21:11

Postby thedoc420 » 10. April 2007 08:45

how is it an osc problem??? register_globals wont turn on and this is like my 100th time restarting my comp...
thedoc420
 
Posts: 3
Joined: 10. April 2007 00:42

Postby Codesmith » 10. April 2007 20:08

1) you only need to stop and start apache after saving changes to php.ini.

2) Run phpinfo() verify that you are editing the correct php.ini file by noting the path to the php.ini file apache is using.

3) Note whether phpinfo() shows register_globals as on or off, don't automatically trust error messages.

4) Assuming you are editing the correct php.ini file and phpinfo() shows its in fact off, search php.ini for all ocurances of "register_globals".

You could have set it to on in one spot then off in another.

Personally ather than render all php code on the server vulnerabl would try out the patch which allows you to run oscommerce with it off.

Very few people here are likely to want register_globals ON. The only reason the setting exists is for compatibility with old code.

I find it very odd that oscommerce hasn't updated by now.

http://www.oscommerce.com/community/contributions,2097

Or use an .htaccess files to turn register globals on, but only for the folder oscommerce is in.

And if you check their forums they have an entire thread devoted to nothing but register_globals problems.
Codesmith
 
Posts: 101
Joined: 31. March 2007 21:11


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 61 guests