Zend Platform 2.2.3 moved my php.ini,want to move it back.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Zend Platform 2.2.3 moved my php.ini,want to move it back.

Postby Codesmith » 01. April 2007 00:33

I just installed XAMPP 1.5.4 and Zend Platform 2.2.3 on a Windows XP Pro SP2 Virtual Machine.

Everything is working :)
My php.ini file is now in the wrong place :(

"C:\Program Files\Zend\ZendPlatform-2.2.3\etc\php.ini "

I would like to change it back to the default location for XAMPP, but I have no clue where to start.

On a side note is there any particular reason I shouldn't be running XAMPP 1.5.4 on my development server?

I tried XAMPP 1.6.0a and Zend Platform 3.0.2 and ran into problems I didn't have time to deal with.

Any help would be appreciated.
Posts: 101
Joined: 31. March 2007 21:11

Postby Codesmith » 14. April 2007 02:07

OK I found the answer to my own question.

This is how you regain the ability to switch between PHP 4 and PHP 5 after installing Zend Platform 2.2.3 on XAMP 1.5.4 and still have Zend Server Debugging work.

(Zend Platform 2.2.3 doesn't like PHP 5.2 so you need a XAMPP using 5.1 if you want to install it)

This will cause the Zend Platform License to Expire, which is fine as server debugging doesn't require an active license and the trial license for the rest of the Zend Platform features expire after 30 days anyway.

Zend Platform adds and environmental variable to windows and a registry key to move the location of the php.ini file to its folder.

It also messes with the apache .conf files, but xampp's php switcher will fix that automatically.

My Computer -> Right Click -> Properties -> Advanced -> Environmental Variables.

Delete phprc=......

Run regedit. Delete Registry Key


Stop Apache if started.

Use XAMPP PHP switcher to switch to PHP 4

Edit php.ini to enable Zend Debugger

Use XAMPP PHP swicther to swich to PHP 5

Edit php.ini to enable Zend Debugger

Start Apache

Changes to php.ini to enable Zend Server Debugging

;PHP 5 only
auto_globals_jit =0

;Change needed for both PHP 4 and PHP 5 for Zend Debugging

zend_extension_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\ZendExtensionManager.dll"
zend_extension_manager.optimizer_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\Optimizer-3.0.2"
zend_extension_manager.platform_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\Platform-2.2.0"
zend_extension_manager.java_bridge_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\JavaMW-1.1.2"
zend_extension_manager.mysql_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\MySQL"
zend_extension_manager.gd_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\GD"
zend_extension_manager.debug_server_ts="C:\Program Files\Zend\ZendPlatform-2.2.3\lib\Debugger-5.2.1"
zend_ini_file="C:\Program Files\Zend\ZendPlatform-2.2.3\etc\zend.ini"
;zend_extension_ts = "C:\Program Files\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
;zend_extension_manager.optimizer_ts = "C:\Program Files\xampp\php\zendOptimizer\lib\Optimizer"
;zend_optimizer.enable_loader = 0
;zend_optimizer.license_path =

; Local Variables:
; tab-width: 4
; End:

I can now switch between php 4 and php 5 and still use Zend Studio 5.50 server debugging. :)
Posts: 101
Joined: 31. March 2007 21:11

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests