IIS to Apache

Problems with the Windows version of XAMPP, questions, comments, and anything related.

IIS to Apache

Postby jimholmes » 26. March 2007 13:02

Hello,

I have just installed the package for windows, as I couldn't take any more disappointment trying to get IIS to work with mysql - now I have it all installed but can't see any web pages from it :-(

As I has a previous installation of IIS, my doc root is inetpub/www
but although I changed that in the httpconf file, it still won't serve any pages??

Any ideas?

Thanks one and all

Jim
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby Wiedmann » 26. March 2007 13:18

it still won't serve any pages

Why not?
- error message
- error.log
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jimholmes » 26. March 2007 13:22

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
03/26/07 13:21:44
Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby Wiedmann » 26. March 2007 13:31

Fine, that's the error message. What's about the error.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jimholmes » 26. March 2007 13:39

Sorry - I no idea where that would be..
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby jimholmes » 26. March 2007 13:40

found it!
[Mon Mar 26 13:21:44 2007] [error] [client 127.0.0.1] File does not exist: C:/Program Files/xampp/htdocs/hills
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby jimholmes » 26. March 2007 13:41

so why is it still looking for the docs there??
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby jimholmes » 26. March 2007 13:43

# DocumentRoot: The directory out of which you will serve your
# documents. By default, all requests are taken from this directory, but
# symbolic links and aliases may be used to point to other locations.
#
DocumentRoot "C:/inetpub/wwwroot"
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby Wiedmann » 26. March 2007 13:50

Code: Select all
DocumentRoot "C:/inetpub/wwwroot"

File does not exist: C:/Program Files/xampp/htdocs/hills

You have changed the correct "httpd.conf" and restarted Apache?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jimholmes » 26. March 2007 14:00

yep.... tried several times and re-booted too just in case...
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby Wiedmann » 26. March 2007 14:05

For a test:
Can you open phpinfo() and look in the output for the DOCUMENT_ROOT value?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jimholmes » 26. March 2007 14:06

interesting...restarted again...just got a different error message:

Access forbidden!

You don't have permission to access the requested object. It is either read-protected or not readable by the server.

If you think this is a server error, please contact the webmaster.
Error 403
localhost
03/26/07 14:05:17
Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby Wiedmann » 26. March 2007 14:07

error.log?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby jimholmes » 26. March 2007 14:08

can't even open the admin page now:

Access forbidden!
You don't have permission to access the requested directory. There is either no index document or the directory is read-protected.

If you think this is a server error, please contact the webmaster.

Error 403
localhost
03/26/07 14:08:31
Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Postby jimholmes » 26. March 2007 14:09

[Mon Mar 26 14:05:17 2007] [error] [client 127.0.0.1] client denied by server configuration: C:/inetpub/wwwroot/hills/concrete_home.php
jimholmes
 
Posts: 10
Joined: 26. March 2007 12:50

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 33 guests