PHP scripts don't work properly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP scripts don't work properly

Postby cookieboi » 22. March 2007 21:23

Hi. I was wondering if anyone could help me..

I have xampp installed on my pendrive and it works fine. I use it for testing out php scripts so i don't have to upload them to my webserver. I can also therefore take the scripts/website around with me and either develop it where ever i want or show it at places with out an internet connection. Anyway, I have php scripts that need register_globals switched on. I have a php.ini file in the root directory that switches it on, and it works on me web server. could someone point out to me what the problem could be. Thanks. (sorry for writing an essay lol :D)

Jamez.
cookieboi
 
Posts: 2
Joined: 22. March 2007 21:17

Postby Wiedmann » 22. March 2007 21:44

could someone point out to me what the problem could be.

What is your problem?

BTW:
I have php scripts that need register_globals switched on.

No script should depend on "register_globals = On"!
--> correct your script.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby cookieboi » 23. March 2007 18:24

yer soz er i include a page depending on a variable set in the address of the page eg.

http://blar.com/index.php?x=contact

would give me the index page and it would include the contact.php into the place where ive put a bit of code in index.php.

and it doesnt work in xampp..

hope ive mad it clearer

jamez. :?
cookieboi
 
Posts: 2
Joined: 22. March 2007 21:17

Postby Wiedmann » 23. March 2007 18:34

where ive put a bit of code in index.php ... and it doesnt work in xampp.

The your "bit of code" is wrong.

BTW:
I's clear, that you are using "error_reporting(E_ALL);" for the debbuging of your scripts?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests