preventing localhost from being overridden by new vh

Problems with the Windows version of XAMPP, questions, comments, and anything related.

preventing localhost from being overridden by new vh

Postby april » 16. March 2007 16:00

Hi,

I've got a virtual host, but sadly, it seems to override the localhost xampp page. How can I get around this? I've tried several different things but none has worked.

In vhosts:

Code: Select all
## local.test.leaf
<VirtualHost *:80>
DocumentRoot G:/web/test.leaf/htdocs
ServerName local.test.leaf
ServerAdmin admin@local.test.leaf
<Directory "G:/web/test.leaf/htdocs/">
Options Indexes FollowSymLinks ExecCGI Includes
AllowOverride All
Order allow,deny
Allow from All
</Directory>
</VirtualHost>


in windows hosts file:
Code: Select all
127.0.0.1  localhost
127.0.0.1  local.test.leaf


One would think changing the local.test.leaf to a different IP would fix this issue but it hasn't. I don't see others complain about this issue, so I'm guessing it's just me. localhost shouldn't be showing the same page as local.test.leaf.
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby Wiedmann » 16. March 2007 16:36

One would think changing the local.test.leaf to a different IP would fix this issue...

That's one possible solution.

... but it hasn't.

Then you've made an error in this configuration scenario.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby april » 16. March 2007 17:05

Any idea where?

So far when I try to set the document root or dir path to:

Code: Select all
<VirtualHost *:80>
ServerName local.test.leaf
ServerAlias test.leaf
DocumentRoot G:/Program Files/xampp/htdocs/web/test.leaf/htdocs
ServerAdmin admin@local.test.leaf
   <Directory "G:/Program Files/xampp/htdocs/web/test.leaf/htdocs">
      Options Indexes FollowSymLinks ExecCGI Includes
      AllowOverride All
      Order allow,deny
      Allow from All
   </Directory>
</VirtualHost>


Apache won't even start.

If I change the docroot to someplace outside of apache it will show that as local host as well as the virtual address...

Error log says:

Code: Select all
[Fri Mar 16 12:04:17 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Mar 16 12:04:17 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Mar 16 12:04:17 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Fri Mar 16 12:04:17 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Fri Mar 16 12:04:18 2007] [notice] Apache/2.2.4 (Win32) DAV/2 mod_ssl/2.2.4 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.1 configured -- resuming normal operations
[Fri Mar 16 12:04:18 2007] [notice] Server built: Jan 30 2007 12:11:56
[Fri Mar 16 12:04:18 2007] [notice] Parent: Created child process 3908
[Fri Mar 16 12:04:20 2007] [notice] Child 3908: Child process is running
[Fri Mar 16 12:04:20 2007] [notice] Child 3908: Acquired the start mutex.
[Fri Mar 16 12:04:20 2007] [notice] Child 3908: Starting 250 worker threads.
[Fri Mar 16 12:04:20 2007] [notice] Child 3908: Starting thread to listen on port 443.
[Fri Mar 16 12:04:20 2007] [notice] Child 3908: Starting thread to listen on port 80.


Any clues? Does something need to be uncommented?
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby Wiedmann » 16. March 2007 17:10

Apache won't even start.

Correct. Start Apache with the batchfile and you see your error.

(BTW: This solves not your initiate problem.)
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby april » 16. March 2007 17:32

The only thing I did other than add virtual hosting is uncomment LoadModule rewrite_module modules/mod_rewrite.so

Nothing else has been touched (ie, it's all default settings). I have no clue what would be causing this.
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby Wiedmann » 16. March 2007 17:56

Once more the same question:
With the above postet config code, you have start the server with the batchfile and read the output?
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby april » 16. March 2007 20:16

Wiedmann wrote:
Apache won't even start.

Correct. Start Apache with the batchfile and you see your error.

(BTW: This solves not your initiate problem.)


All it says is "Apache 2 is starting..." Unless it's supposed to say something else I'm not getting an error message.
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby april » 16. March 2007 20:47

Has no one else had an issue with VH domains running over localhost?
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby april » 16. March 2007 21:40

Well, I finally found the little issue with the VH name. (Damn browser caching...) I was forced to change the IP...

Now to beat these last few errors from my error log...
april
 
Posts: 24
Joined: 09. January 2007 19:06

Postby Wiedmann » 16. March 2007 21:43

All it says is "Apache 2 is starting..."
I'm not getting an error message.

Then Apache is working.

But why have you post:
april wrote:Apache won't even start.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby april » 19. March 2007 13:37

Because I was referring to the above snippet of code where the Docroot was pointed inside xampp's folders.
april
 
Posts: 24
Joined: 09. January 2007 19:06


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests