Can't access my site!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't access my site!

Postby henky » 09. March 2007 17:23

Hello, I can open my site by typing localhost or 127.0.0.1 in the address bar, when I type ipconfig in command prompt it sais my ip is different then www.myip.nl tells me, I try both on another network then mine, and the internet sais it can't find nor the ipconfig tells me nor myip.nl tells me,
please help, I've got apache running.
henky
 
Posts: 5
Joined: 08. March 2007 16:29

Postby WorldDrknss » 10. March 2007 11:25

The default install of xampp has local access only. (127.0.0.1 or localhost) and it looks like you are using a router so there are necessary ports that need to be opened.

These are the ports as follow:
http 80 (HTTP)
https 443 (SSL)
mysql 3306
And for all other servers in XAMPP:
ftp 21
smtp 25
pop3 110
imap 143
AJP/1.3 8009
http-alt 8080 (Tomcat Default Port)

To get by local access only you can create a VirtualHost (Recommened) or make the following change to httpd.conf:
Code: Select all
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

to
Code: Select all
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>

Use the second method at your own risk.
http://wdguides.org - XAMPP Tutorials & MORE!!!!
User avatar
WorldDrknss
 
Posts: 292
Joined: 17. September 2005 13:40

Postby henky » 13. March 2007 16:25

WorldDrknss wrote:The default install of xampp has local access only. (127.0.0.1 or localhost) and it looks like you are using a router so there are necessary ports that need to be opened.

These are the ports as follow:
http 80 (HTTP)
https 443 (SSL)
mysql 3306
And for all other servers in XAMPP:
ftp 21
smtp 25
pop3 110
imap 143
AJP/1.3 8009
http-alt 8080 (Tomcat Default Port)

To get by local access only you can create a VirtualHost (Recommened) or make the following change to httpd.conf:
Code: Select all
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

to
Code: Select all
<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Allow from all
</Directory>

Use the second method at your own risk.


ok tnx! I have set my pc as the default server so my firewall is disabled, if it works I'll simply open the ports in napt config and then reanable the firewall, but please help with this:
my port add screen looks like this:

protocol: udp/tcp, which do I choose?
inside ip: this should be my pc's ip right?
inside port: what should I enter here?
outside ip: I should leave this blank right?
outside port: what do I fill in here?

tnx :)
henky
 
Posts: 5
Joined: 08. March 2007 16:29

Postby henky » 13. March 2007 19:30

Nevermind! got it working! :D
henky
 
Posts: 5
Joined: 08. March 2007 16:29


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests