Newbie enquiry

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Newbie enquiry

Postby addACUMEN » 02. March 2007 22:38

I have previously had Apache and MySQL running on my Windows XP machine.

I want to use a framework, eg Seagull, and my reading seemed to suggest that using XAMPP would produce a more robust basis for this adventure.

I uninstalled Apache, MySQL, PHP, Pear, etc and downloaded XAMPP today. XAMPP installed without problem. The control panel reports that Apache, MySQL and FTP are all working as services.

However in Firefox http://localhost and http://127.0.0.1 tell me that they cannot connect.

I have examined php.ini and httpd.conf and they seem to be set up correctly.

Please can you tell me what else I should look for and where?

Apologies for being such a fool.
Thank you for your help

Tony D
addACUMEN
 
Posts: 15
Joined: 02. March 2007 22:26
Location: Wengen, Switzerland

Some problems solved but still a query.

Postby addACUMEN » 03. March 2007 10:06

I decided to try to be helpful to anyone who would try to respond but then I unravelled most of my difficulties.

xampp-portcheck shows that the ports are FREE.

Xampp control panel shows Apache and MySQL as State 0 Service 1 Start 1 Thread 0 Op 0

Task Manager does NOT show Apache or MySQL running

Use of the .bat files to Start Apache and MySQL produced cmd.exe windows reporting that they both started.

Task Manager still does NOT show they are running but . . .

Access to localhost now worked and displayed the XAMPP home page and xampp-portcheck shows that the ports are occupied by Apache for http and https and MySQL holds its port.

So I had somehow set everything up but had not started Apache and MySQL.

Please tell me what I need to do to get Apache and MySQL to start from the XAMPP controller.
Thank you for your help

Tony D
addACUMEN
 
Posts: 15
Joined: 02. March 2007 22:26
Location: Wengen, Switzerland

Postby ntsmarkv » 04. March 2007 19:12

Do me a favor go to:

Start--> Control Panel --> Administration Panel --> Services

scroll down to mysql and tell us the path it's at.. thats probably your problem it's at wrong path..

if it is, then you need to go to the dos prompt CD to that folder, then type:

"mysql remove" - no quotes. this will remove mysql the correct way then just reinstall at right path..

if at right path your router is blocking it.
ntsmarkv
 
Posts: 32
Joined: 22. October 2005 21:38

Postby addACUMEN » 05. March 2007 13:28

The mysql service says that it is running

Program Files\applicationweb\mysql\bin\mysql-nt.exe

CD to that directory gets

1. mysql is not recognised
2. dir shows there are no files in the directory.

There is a copy of mysql-nt.exe at

Program Files\xampp\mysql\bin\

Any recommendations will be gratefully received.
Thank you for your help

Tony D
addACUMEN
 
Posts: 15
Joined: 02. March 2007 22:26
Location: Wengen, Switzerland

Postby Wiedmann » 05. March 2007 15:41

I uninstalled Apache, MySQL,

That's the problem, you have only removed the applications, but not the services.

In a command prompt make a:
Code: Select all
sc delete mysql


Now you can reinstall the MySQL service from XAMPP.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 40 guests