mysqld.exe has encountered a problem...

Problems with the Windows version of XAMPP, questions, comments, and anything related.

mysqld.exe has encountered a problem...

Postby mikeprince » 27. February 2007 07:54

I have just installed Xampp 1.6.0a on a new PC. From the Xampp Control Panel I can start (and stop) Apache without any problems. However, when I attempt to start MySQL I get a Windows pop-up "mysqld.exe has encountered a problem and needs to close...". Can't be sure of the exact wording since almost immediately I then get a DrWatson PostMortem Debugger pop-up. I tried stopping Apache and restarting and then got a couple of similar errors, including one with "pv.exe has encountered a problem...".

This is on Windows XP Pro SP2 with no significant other software running, i.e. no antivirus, no firewall. I'm free from viruses and adware/spyware. The Xammp port check reports all ports as free.

Would very much appreciate some help because I'm at a bit of a loss with this one!

Cheers
-- Mike --
mikeprince
 
Posts: 3
Joined: 27. February 2007 06:05

Postby mikeprince » 03. March 2007 13:49

Does no-one have any ideas for this? I've even tried reinstalling Windows and still get the same problem.
mikeprince
 
Posts: 3
Joined: 27. February 2007 06:05

Postby mikeprince » 03. March 2007 14:19

It is actually not a MySQL problem - I just started then stopped Apache and it was fine. I did the same again and it was fine. Then when I tried to start Apache for a third time I got a message something like "Apache web server has encountered a problem...". This was immediately followed by Data Execution Prevention (DEP) "To help protect your computer, Windows has closed this program" for DrWatson Postmortem Debugger".

I then can't close this window so end up rebooting.

Hope this helps someone come up with some ideas!

Cheers
-- Mike --
mikeprince
 
Posts: 3
Joined: 27. February 2007 06:05

Re: mysqld.exe has encountered a problem...

Postby FloWIKI » 12. May 2009 11:46

Did you ever find a fix for this?

I am having a similar issue! Had my XAMPP installed at c:/Program FIles/xampp.... but had to move it due to cgywin issues. Moved it to c:/xampp.
All fine, but couldnt get the wiki to run when i was logged off
Realised the apache and mysql services still had 'Program Files' in thier path
Changed their registry to the correct path
Now apache works fine, but mysqld.exe crashes everytime i try to run it :(

Anyone out there in Internet-land got a fix?
FloWIKI
 
Posts: 5
Joined: 27. March 2009 13:21


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests