XAMPP 1.6.0a and osCommerce ....

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.6.0a and osCommerce ....

Postby BIF » 23. February 2007 13:46

Hello!

I have an osc site up and running and I need to have a development area on my machine so I can refine the site without breaking the live site.

I have just downloaded and installed XAMPP as above and I am having some problems, to run osCommerce I had to switch to PHP 4 plus also set register_globals to On, this worked fine. I also setup a specific dbase and user just for osc.

I have been through the osc web-based install with no problems, all the dbase scripts run and everything seems fine, however when I go to use the site I get the following Windows error;

'Apache HTTP Server has encountered a problem and needs to close. We are sorry for the inconvenience.'

I am running XP SP2 with all the latest security patches

At this point you cannot even browse to a normal html page and I have to stop and restart Apache via the XAMPP control panel.

Can anyone help? - Things where going so brilliantly - I must say that this one of the slickest + easiest pieces of software I have ever used! If I can get past this problem I will be very happy!

I have the dump file from the Windows error if this is of use.

Thanks in advance,

BIF. :(
BIF
 
Posts: 3
Joined: 23. February 2007 13:25
Location: Basildon, UK

Postby BIF » 23. February 2007 18:26

Ok - Please dont all rush at once! :wink:

I think there is a problem with the latest XAMPP release - I uninstalled 1.6.0a and downloaded 1.4.16 on the basis that this was probably a more mature release and I have seen people pointed to version 1.4.? for other reasons.

Everything now works, but someone might what to resolve whatever the issue is in case it has an effect on other applications.

I could be completely wrong of course and just making a schoolboy error!

Thanks,

BIF. :)
BIF
 
Posts: 3
Joined: 23. February 2007 13:25
Location: Basildon, UK

Postby Robin » 24. February 2007 07:48

Me too. Everything seems to work fine except osCommerce. Using Win XP pro.
Anyone knows the problem?.... ver 1.6.0a seems to have some unsolved problems. Might change back to 1.5.4a... atleast it works with osCommerce. :roll:
Robin
 
Posts: 1
Joined: 23. February 2007 15:15

Postby BIF » 24. February 2007 11:33

Robin wrote:Me too. Everything seems to work fine except osCommerce. Using Win XP pro.
Anyone knows the problem?.... ver 1.6.0a seems to have some unsolved problems. Might change back to 1.5.4a... atleast it works with osCommerce. :roll:


Robin - Thank goodness someone else is having the same problem!

At least I know now that it is not just me - anyone got any ideas? :?

BIF
BIF
 
Posts: 3
Joined: 23. February 2007 13:25
Location: Basildon, UK


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests