Apache won't start [RESOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start [RESOLVED]

Postby bellesmanieres » 20. February 2007 13:03

Hi,
I've been searching for a while know, but I can't get Xampp to work on a Windows Home edition SP2.
Here is a copy of the error log I get when trying to start Apache :

[Tue Feb 20 12:27:31 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Feb 20 12:27:31 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Feb 20 12:27:35 2007] [crit] (22)Invalid argument: unable to replace stderr with error_log
[Tue Feb 20 12:27:35 2007] [crit] (2)No such file or directory: unable to replace stderr with /dev/null
[Tue Feb 20 12:27:39 2007] [notice] Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 configured -- resuming normal operations
[Tue Feb 20 12:27:39 2007] [notice] Server built: Sep 30 2006 21:24:06
[Tue Feb 20 12:27:39 2007] [notice] Parent: Created child process 3860
[Tue Feb 20 12:27:46 2007] [notice] Child 3860: Child process is running
[Tue Feb 20 12:27:46 2007] [crit] (OS 10022)Un argument non valide a été fourni. : Child 3860: setup_inherited_listeners(), WSASocket failed to open the inherited socket.
[Tue Feb 20 12:27:46 2007] [crit] Parent: child process exited with status 3 -- Aborting.

By the way, Apache is not the only application no to work : since I've tried it, it seems like all server-like applications won't work : EasyPHP and FilezillaServer, wich I both used not so far ago, won't start either (but Soulseek P2P app works !?)

What i've tried so far :
- desinstalling my firewall (Filseclab Personal)
- fixing winsocks setting using Winsock2Fix as given in the FAQ
- fixing winsocks setting using Dial-a-Fix
- uninstalling / reinstalling Xampp and/or Xampplite with/without the installer
- probably a few over things I have forgotten
- stopping every running apps that could conflict or block it (Avast Antivirus, DynDNS Updater, Spybot resident : that's all I usually launch at start up)

Ports are checked free, there's no memory hog.
I can't remember having installed anything special that could have messed up with settings except Windows security updates and IE7.

So, if someone had any clue about where to seek...

Thanks a lot

EDIT:
I uninstalled Filseclab once again and this time, it worked ! I guess I hadn't uninstalled properly at first attempt or something.
So, everything's running smoothly without firewall, I just have to reinstall Filseclab and mess up with the settings until it won't block.
Why it suddenly blocked other apps, like Filezilla, that worked fine before remains a mistery to me but...
bellesmanieres
 
Posts: 1
Joined: 20. February 2007 12:30

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 29 guests