XAMPP and Mambo 4.5.2 & SMF 1.0.1 error

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP and Mambo 4.5.2 & SMF 1.0.1 error

Postby Denise » 31. January 2007 00:27

Hi. Question 1; is this even possible, and if so, does it need special settings other than switching to PHP4? I also already turned registers_global on in php.ini, anything else?

Can't get it to work. It spits out this:
Code: Select all
Warning: main(E:\Program Files mpp\htdocs\localstart\dynamic/SSI.php) [function.main]: failed to open stream: Invalid argument in E:\Program Files\xampp\htdocs\localstart\static\templates\rhuk_solarflare_ii\index.php on line 51

Fatal error: main() [function.require]: Failed opening required 'E:\Program Files mpp\htdocs\localstart\dynamic/SSI.php' (include_path='.;E:\Program Files\xampp\php\pear\') in E:\Program Files\xampp\htdocs\localstart\static\templates\rhuk_solarflare_ii\index.php on line 51


Here's line 51:
Code: Select all
require ($smf_path."/SSI.php");


Now, when approaching the forum directly it gives me a page with no layout but the links to the boards are present. If I hover them, they show:
Code: Select all
http://localhost/localstart/dynamic/localhost/localstart/dynamic/index.php?board=4.0

So maybe that points to where it goes wrong. When I left out the "localhost/localstart/dynamic" statement in SMF's configuration file where it asks for the board url, the links only showed http://localhost/index.php?board=4.0.

Any experience welcome :shock:
Denise
 
Posts: 4
Joined: 30. January 2007 00:12

Postby Wiedmann » 31. January 2007 01:08

Warning: main(E:\Program Files mpp\htdocs\localstart\dynamic/SSI.php) [function.main]: failed to open stream:

require ($smf_path."/SSI.php");

There is something wrong with your variable "$smf_path".
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Denise » 31. January 2007 08:09

You mean this setting?
Code: Select all
$boarddir = 'E:\Program Files\xampp\htdocs\localstart\dynamic';      # The absolute path to the forum's folder.

I obtained it through using a PHP file that told me the true path.

This reminds me: How can I set permissions om XAMPP Windows 2000? Maybe that's involved too?
Denise
 
Posts: 4
Joined: 30. January 2007 00:12

Postby Wiedmann » 31. January 2007 09:09

You mean this setting?

I can't see "$smf_path" in this setting...
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Denise » 31. January 2007 09:22

Ah it's in the com_smf\config.smf.php folder:

Code: Select all
$smf_path = "E:\Program Files\xampp\htdocs\localstart\dynamic";
Denise
 
Posts: 4
Joined: 30. January 2007 00:12

Postby Wiedmann » 31. January 2007 09:39

Ah, now :-)

As in your sample before, you must use single quotes and not double quotes for the string.

BTW:
You can always use forwardslashs, instead of backslashs, to prevent this problem.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Denise » 31. January 2007 10:42

I changed all E:\ etc instances into E:/ instances. That brought us one step closer! There is no template yet, but the content appears very roughly.

When I approach the forum seperately again, the double url is still there: http://localhost/localstart/dynamic/loc ... ?board=4.0, so perhaps solving that will be the second piece of the puzzle?
Denise
 
Posts: 4
Joined: 30. January 2007 00:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 69 guests