Can't open phpMyAdmin

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Can't open phpMyAdmin

Postby tryin_to_learn » 18. January 2007 16:23

I installed XAMPP and got the messages saying it's installed correctly but I can't access phpMyAdmin. When I try via the Control Panel, I get a 404 page not found. I noticed that link was all lowercase (phpmyadmin) whereas the folder is actually phpMyAdmin, but changing the URL to that still gives a page not found. I tried entering the whole URL

(http://localhost/phpMyAdmin/index.php)

and also http://localhost/xampp/phpMyAdmin/index.php

and I still get a page not found.

I tried switching between PHP 4 and PHP 5 to see if that made a difference, but I still can't access it. Any ideas on what's going wrong or what else I can try?
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby Izzy » 18. January 2007 22:49

Try your xampp\apache\logs\error.log and find the part that is referring to the date and time you get these 404 errors. Usually there is more factual info for you to work with.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby Wiedmann » 18. January 2007 23:56


Both URIs are wrong. The correct one is:
http://localhost/phpmyadmin/
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tryin_to_learn » 19. January 2007 03:29

Izzy wrote:Try your xampp\apache\logs\error.log and find the part that is referring to the date and time you get these 404 errors. Usually there is more factual info for you to work with.


I checked and the file is blank -- zero KB and nothing at all on it when I open it.
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby tryin_to_learn » 19. January 2007 03:31

Wiedmann wrote:

Both URIs are wrong. The correct one is:
http://localhost/phpmyadmin/


That was the one I tried first. I get this:

Not Found

The requested URL /phpmyadmin/ was not found on this server.
Apache/2.0.54 (Win32) PHP/5.0.4 Server at localhost Port 80

That's when I checked and found that in my version of XMAPP, the name of the folder is camel case: phpMyAdmin -- but changing the URL to that produces the same results.
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby Izzy » 19. January 2007 05:14

tryin_to_learn wrote:I checked and the file is blank -- zero KB and nothing at all on it when I open it.

Here is a major problem.
The 404 page not found error is issued by the server and if it had been XAMPP's Apache component there would have been an entry in the error log I mentioned.

Here is what a 404 error issued by Version 1.5.5 of XAMPP's Apache looks like in Mozilla's browser SeaMonkey and should look similar in other browsers.
Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
01/19/07 14:00:32
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 mod_jk/1.2.15 mod_perl/2.0.2 Perl/v5.8.8

Because the above error message includes the date and time it is quite easy to check the error log entry for that reference:
01/19/07 14:00:32
Here is the corresponding error.log entry I get when I tried to simulate your issue:
[Fri Jan 19 14:00:32 2007] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/phpMyAdmin


Is XAMPP's Apache running?

http://localhost/xampp/ should get you to the Welcome to XAMPP for Windows Version 1.5.5! page.

From this page, if you click on phpMyAdmin in the left frame menu tree, which is linked to http://localhost/phpmyadmin/ you will have the entry page to phpMyAdmin displayed in the main page frame.

Do you have another instance of Apache on your PC?
XAMPP requires exclusive use of ports 80 and 443

Run xampp\xampp-portcheck.exe to see what is running on the ports XAMPP uses.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby tryin_to_learn » 19. January 2007 15:04

Izzy wrote:
tryin_to_learn wrote:I checked and the file is blank -- zero KB and nothing at all on it when I open it.

Here is a major problem.
The 404 page not found error is issued by the server and if it had been XAMPP's Apache component there would have been an entry in the error log I mentioned.

Here is what a 404 error issued by Version 1.5.5 of XAMPP's Apache looks like in Mozilla's browser SeaMonkey and should look similar in other browsers.
Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404
localhost
01/19/07 14:00:32
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.2.0 mod_jk/1.2.15 mod_perl/2.0.2 Perl/v5.8.8

Because the above error message includes the date and time it is quite easy to check the error log entry for that reference:
01/19/07 14:00:32
Here is the corresponding error.log entry I get when I tried to simulate your issue:
[Fri Jan 19 14:00:32 2007] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/xampp/phpMyAdmin


Is XAMPP's Apache running?

http://localhost/xampp/ should get you to the Welcome to XAMPP for Windows Version 1.5.5! page.

From this page, if you click on phpMyAdmin in the left frame menu tree, which is linked to http://localhost/phpmyadmin/ you will have the entry page to phpMyAdmin displayed in the main page frame.

Do you have another instance of Apache on your PC?
XAMPP requires exclusive use of ports 80 and 443

Run xampp\xampp-portcheck.exe to see what is running on the ports XAMPP uses.


Ok, we're getting there but I don't know how to fix it. http://localhost/xampp goes to the XAMPP page. However, running the xampp-portcheck.exe gives the following:

Apache <HTTP> Port 80 C:\Program Files\Apache Group\Apache2\bin\Apache.exe

Apache <WebDAV> Port 81 free
Apache <HTTPS> port 443 free

MySQL Port 3306 free

Then it goes into FileZilla and Mercury.

So it looks like I do have another version of Apache, right? How do I fix this? Thanks so much for your help, btw. I'm pretty new to all of this.
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby tryin_to_learn » 19. January 2007 17:39

I took out the Apache Group folder in C:\Program Files. Now, though, when I try to access

http://localhost/xampp/

I get an unable to connect error: Firefox can't establish a connection to the server at localhost. I checked httpd.conf in the xampp/apache folder and it's set like this, which is correct, right?

ServerRoot "C:/Program Files/xampp/apache"

I'm not sure what to try next.
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04

Postby Wiedmann » 19. January 2007 20:46

I'm not sure what to try next.

Start the Apache webserver (from the XAMPP package).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby tryin_to_learn » 20. January 2007 03:13

Wiedmann wrote:Start the Apache webserver (from the XAMPP package).


Got it! I ended up having to disable the Apache service that had been running before and then uninstall and reinstall XAMPP. It seems to be working fine now. Thanks!
tryin_to_learn
 
Posts: 54
Joined: 18. January 2007 16:04


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests