XAMPP's PHP is broken against Sybase Client Library v.15

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP's PHP is broken against Sybase Client Library v.15

Postby jbridge » 15. January 2007 10:01

I just installed XAMPP, but php_sybase_ct.dll is linked against libct.dll which doesn't exist any more in Sybase Client Library v.15.

Are there any plans to support this?

Thanks a lot! :D
jbridge
 
Posts: 2
Joined: 15. January 2007 09:47

Re: XAMPP's PHP is broken against Sybase Client Library v.15

Postby Izzy » 15. January 2007 12:16

jbridge wrote:I just installed XAMPP, but php_sybase_ct.dll is linked against libct.dll which doesn't exist any more in Sybase Client Library v.15.

Are there any plans to support this?

Thanks a lot! :D

This seems to be a global issue that is being experienced by many.
The solution may have to come from PHP to upgrade the dll extension to include the renamed sybase dll names.

However I found a possible workaround from Sybase on this site:
http://www.embarcadero.com/resources/re ... tisan.html

Workaround: In the Sybase 15 release, Sybase renamed libct.dll and libcs.dll to libsybct.dll and libsybcs.dll, respectively. Sybase has provided a batch command that will rename the files to pre-15 names. It's located in c:\sybase_client_install_folder\locs-15_0\scripts and the file name is copylibs.bat


I hope it helps with your Sybase issue in the mean time.
Let us know how it goes please.
Good luck. :)
Last edited by Izzy on 16. January 2007 11:45, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby jbridge » 15. January 2007 14:23

You're excellent.

It works perfectly. Thanks! 8)
jbridge
 
Posts: 2
Joined: 15. January 2007 09:47


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests