zend not working?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

zend not working?

Postby grayson9 » 08. January 2007 03:44

I am trying to look at a script but everytime i go to look at it i get the following error :shock:
Zend Optimizer not installed
This file was encoded by the Zend Encoder / Zend SafeGuard Suite

In order to run it, please install the freely available Zend Optimizer, version 2.1.0 or later.

What is the Zend Optimizer?
The Zend Optimizer is one of the most popular PHP plugins for performance-improvent, and has been freely available since the early days of PHP 4. It improves performance by taking PHP's intermediate code through multiple Optimization Passes, which replace inefficient code patterns with efficient code blocks. The replacement code blocks perform exactly the same operations as the original code, only faster.

In addition to performance-improvement, the Zend Optimizer also enables PHP to transparently load files encoded by the Zend Encoder or Zend SafeGuard Suite.

The Zend Optimizer is a freely-available product from Zend Technologies. Zend Technologies is the company that develops the scripting engine of PHP, also known as the Zend Engine.

I searched the forum and updated my php"ini" file as recommended and restarted xampp and still i get the same message.
Here is my php script that was changed

[eAccelerator]
extension=eaccelerator.dll
eaccelerator.shm_size = "0"
eaccelerator.cache_dir = "C:\Program Files\xampp\tmp"
eaccelerator.enable = "1"
eaccelerator.optimizer = "0"
;eaccelerator.debug = "0"
;eaccelerator.check_mtime = "1"
;eaccelerator.filter = ""
;eaccelerator.shm_max = "0"
;eaccelerator.shm_ttl = "0"
;eaccelerator.shm_prune_period = "0"
;eaccelerator.shm_only = "0"
;eaccelerator.compress = "1"
;eaccelerator.compress_level = "9"
;eaccelerator.keys = "shm_and_disk"
;eaccelerator.sessions = "shm_and_disk"
;eaccelerator.content = "shm_and_disk"
;eaccelerator.admin.name =
;eaccelerator.admin.password =

[Zend]
;zend_extension_manager.optimizer_ts = "C:\Program Files\xampp\php\zendOptimizer\lib\Optimizer"
zend_extension_ts = "C:\Program Files\xampp\php\zendOptimizer\lib\ZendExtensionManager.dll"
zend_optimizer.enable_loader = 0
zend_optimizer.optimization_level=15
;zend_optimizer.license_path =


; Local Variables:
; tab-width: 4
; End:

I am completely lost at this point!
Any ideas
Grayson9 :?: :?: :?:
grayson9
 
Posts: 9
Joined: 08. January 2007 03:33

Postby Wiedmann » 08. January 2007 03:58

Code: Select all
Zend Optimizer not installed

I searched the forum and updated my php"ini" file as recommended and restarted xampp and still i get the same message.

This is a bug in the current XAMPP 1.5.5. The included ZendOptimizer 3.0.2 is not compatible to PHP 5.2.0.

You can switch to PHP4 or install the current ZendOptimzer 3.2.0 from the Zend homepage.
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Izzy » 08. January 2007 04:03

Download latest:
http://downloads.zend.com/optimizer/

Download ZendOptimiser 3.2.0:
http://downloads.zend.com/optimizer/3.2.0/

Follow installer to your XAMPP installation.

Trying to find the above links on the Zend web site can be a nightmare. ;)

BTW - the php.ini to use is in the xampp\apache\bin directory
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Thank you

Postby grayson9 » 08. January 2007 05:20

Thank you and i will try what you say
grayson9
 
Posts: 9
Joined: 08. January 2007 03:33


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests