Using php on xampp

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Using php on xampp

Postby hap_zax » 05. January 2007 22:56

Do we have to install zend Engine in order to use php on xampp?
hap_zax
 
Posts: 14
Joined: 19. December 2006 16:32

Postby Izzy » 05. January 2007 23:14

http://localhost/phpinfo.php will tell you if the Zend Scripting Language Engine is already installed.

[Edit]
Correction - the above address should have been:
http://localhost/xampp/phpinfo.php
That address would not have produced a '404 file not found' error.
[/Edit]
Last edited by Izzy on 06. January 2007 01:05, edited 1 time in total.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hap_zax » 05. January 2007 23:35

it gives me a Error 404

Thanks
hap_zax
 
Posts: 14
Joined: 19. December 2006 16:32

Postby Izzy » 05. January 2007 23:50

hap_zax wrote:it gives me a Error 404

Thanks

xampp\logs\error.log may give you some clues on the 404 file not found error.

Your XAMPP apache server is started/running?

What do you see when you type http://localhost only in your browser?
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hap_zax » 05. January 2007 23:59

Izzy wrote:xampp\logs\error.log may give you some clues on the 404 file not found error.

Your XAMPP apache server is started/running?

What do you see when you type http://localhost only in your browser?


when i type http://localhost

it says its working, but i havent installed zend is that why its saying not able to run php.

Thanks
hap_zax
 
Posts: 14
Joined: 19. December 2006 16:32

Postby Izzy » 06. January 2007 00:11

hap_zax wrote:when i type http://localhost

it says its working, but i havent installed zend is that why its saying not able to run php.

Thanks

Try and paste here the actual error messages you see.

When you type http://localhost you should see the XAMPP welcome page.

XAMPP will work out-of-the-box with no configuration tweaks or additional installed components (I believe Zend is installed by default) if your installation is not corrupted.

Double click xampp\xampp-portcheck.exe and see if anything else is using the ports that XAMPP requires.
The most likely culprits that may be using the XAMPP ports are Skype and IIS. Make sure niether of those are running when you try and start XAMPP components.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hap_zax » 06. January 2007 00:15

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.
Error 404
localhost
01/05/07 23:01:33
Apache/2.2.3 (Win32) DAV/2 mod_ssl/2.2.3 OpenSSL/0.9.8d mod_autoindex_color PHP/5.1.6 mod_perl/2.0.2 Perl/v5.8.8

well when i type

http://localhost/xampp

then the xampp appears, and the port is completely fine, i am not using IIS /Skype - the port is being used by xampp
hap_zax
 
Posts: 14
Joined: 19. December 2006 16:32

Postby Izzy » 06. January 2007 00:27

Type http://localhost/xampp/phpinfo.php or click on the phpinfo() menu item in the left hand menu tree of the XAMPP Welcome page.

If you see the XAMPP Welcome screen when you type http://localhost/xampp/ then php is working fine as that page requires php.

In the xampp\htdocs\ directory you may have put your own index file for your site or made some other configuration changes.

So if you want any of the XAMPP features you need to use the http://localhost/xampp/ address.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby hap_zax » 06. January 2007 01:01

cool thank you soooo much
hap_zax
 
Posts: 14
Joined: 19. December 2006 16:32


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 83 guests