Probs updating - XAMPP for Win 1.53a to XAMPP for Win 1.55

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Probs updating - XAMPP for Win 1.53a to XAMPP for Win 1.55

Postby John Hjorth » 28. December 2006 21:22

To day I have updated my XAMPP for Win 1.53a to XAMPP for WIN 1.55 using the scripts :

1 Selfextracting 7zip : Update XAMPP 1.53 to XAMPP 1.54
2 Selfextracting 7zip : Update XAMPP 1.54 to XAMPP 1.55.

Everything is working just fine under operation, but if I go to PHPinfo in XAMPP´s control panel, I get the information, that PHP is version : 5.1.4.

Welcome message in entracepage says, that XAMPP 1.5.5. is installed.

According to documentation, PHP version 5 of PHP in XAMPP 1.55 should be 5.2.0.

phpMyAdmin in control panel is 2.9.1.1 according to controlpanel, which seems to be correct.

I have tried to delete temporary internet files in my browser to be sure, that I get the correct info.

Any help would be much appreciated.
User avatar
John Hjorth
 
Posts: 24
Joined: 19. August 2006 16:23
Location: Odense, Denmark

Postby John Hjorth » 29. December 2006 00:17

I still can't get it to work - now I have deleted everything and installed from scratch - still no luck.

It seems that there are some files in a subfolder of the xampp folder that I´m not able to delete in Windows - how do I fix that ?
User avatar
John Hjorth
 
Posts: 24
Joined: 19. August 2006 16:23
Location: Odense, Denmark

Postby Izzy » 29. December 2006 00:53

John Hjorth wrote:I still can't get it to work - now I have deleted everything and installed from scratch - still no luck.

It seems that there are some files in a subfolder of the xampp folder that I´m not able to delete in Windows - how do I fix that ?

Make sure that non of the XAMPP components are running before you try and delete the directories. Also make sure the XAMPP Control Panel is not running.

Check this by running the Task Manager and looking for apache.exe (2) mysqld.exe or mysqld-nt.exe or FileZillaServer.exe or mercury.exe in the Processes tab.
Right click on the Task Bar>Task Manager>Processes

If any of the above are evident then right click on the exe file and select End Process then Yes to the question when asked.

If there are non of the above exe files in the Processes tab and you have exited the XAMPP CP you may have to do this to get rid of any services that might have stuck:

At a command prompt start>Run...>cmd.exe
Type
sc delete mysql
Hit Enter
Type:
sc delete apache2
Hit Enter
Type:
sc delete "FileZilla Server"
Hit Enter

Now try and delete the directories and proceed to reinstall XAMPP's new version.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby John Hjorth » 29. December 2006 14:54

Izzy,

That exactly did the trick.

My update from XAMPP 1.53a to XAMPP 1.54 using the selfextracting 7zip went fine, but running the update (again) from XAMPP 1.54 to XAMPP 1.55 using the selfextracting 7zip really screwed things up, the PHP version ended up fine, but phpMyAdmin was simply broken.

Well, after reading your reply to my question I noted not one, but two small icons in my processline on screen - Both Apache and MySQL was still running. :oops:

I have now joined the mailing list, so I will not get behind the wagon again with updates, and at the next update I promise to use the inside of my head also, and to be more carefull.

Thank you for your always kind, precise and fast help.

And thank you to Apache Friends for a buttkicking piece of software - I really love it, and can't live without it, since I got it.
User avatar
John Hjorth
 
Posts: 24
Joined: 19. August 2006 16:23
Location: Odense, Denmark


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 26 guests