localhost only works for a little while..... >:(

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Postby bobleny » 31. December 2006 19:23

Of course I've been downloading the full version. I'm not dumb.

I've been downloading the files from here:
http://www.apachefriends.org/en/xampp-windows.html

devel package and upgrade packages are underneath the full version, which is the version I've been downloading. You must have something to upgrade before you can upgrade it.

XAMPP for Windows 1.5.5, November 26th 2006

Version
Size
Content
XAMPP Windows 1.5.5
[Basic package] Apache HTTPD 2.2.3, MySQL 5.0.27, PHP 5.2.0 + 4.4.4 + PEAR + Switch, MiniPerl 5.8.7, Openssl 0.9.8d, phpMyAdmin 2.9.1.1, XAMPP Control Panel 2.3, Webalizer 2.01-10, Mercury Mail Transport System für Win32 und NetWare Systems v4.01a, FileZilla FTP Server 0.9.20, SQLite 2.8.15, ADODB 4.93, Zend Optimizer 3.0.2, XAMPP Security. For Windows 98, 2000, XP. See also README

Installer [MD5] 33 MB Installer
ZIP [MD5] 86 MB ZIP archive
EXE (7-zip) [MD5] 28 MB Selfextracting 7-ZIP archive


I downloaded the all three of them, checked the MD5 and they match. I also looked in "xampp\apache\bin" none of them contain a "php.exe"
bobleny
 
Posts: 25
Joined: 19. December 2006 05:07

Postby Wiedmann » 31. December 2006 19:27

I also looked in "xampp\apache\bin" none of them contain a "php.exe"

You know the file search from Windows?

BTW:
\xampp\php\php.exe
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby bobleny » 31. December 2006 19:51

Wiedmann wrote:
I also looked in "xampp\apache\bin" none of them contain a "php.exe"

You know the file search from Windows?
Yes, I do know windows search.... What about it?

Wiedmann wrote:BTW:
\xampp\php\php.exe
Yes, that is what I said earlier but izzy, said to look in "xampp\apache\bin".

Izzy wrote:
bobleny wrote:Well, maybe thats the problem!? There is no "php.exe" file in the directory "C:\Program Files\xampp\apache\bin".


That is your problem.
Apache in XAMPP use the php.exe and the php.ini file in the bin directory.

You have a bad installation.

Try a clean uninstall and reinstall useing the installer version and try again or use the zip file and unpack the archive manually to a directory of your choice. I prefer that method as I like my install in the c: directory so I have c:\xampp\[files].
bobleny
 
Posts: 25
Joined: 19. December 2006 05:07

Postby Wiedmann » 31. December 2006 20:08

Sorry, I don't know your real problem, because I don't read the complete thread.

I only answered your last question: Where is the "php.exe" (and with the Windows file search it's really easy to find this file).
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

Postby Izzy » 31. December 2006 21:12

Ignore my posts that referenced a php.exe file in the apache\bin directory ( I have edited them out), the installed php.exe is indeed in the \php directory.
I copied a version of php.exe into my apache\bin directory for another purpose some time back.

The point that I can no longer help you on this issue still stands.
Izzy
 
Posts: 3344
Joined: 25. April 2006 17:06

Postby bobleny » 31. December 2006 22:02

At what point was that?
bobleny
 
Posts: 25
Joined: 19. December 2006 05:07

Postby bobleny » 31. December 2006 22:15

Ok, now that we know the correct directory of the php.exe, should we do that one thing, with the renaming of a file, to make sure there isn't a conflict with the WAMP and the php thing that you thought was happening because the phpinfo() file would stall the browser...

I would quote you and show you , but you deleted the post....
bobleny
 
Posts: 25
Joined: 19. December 2006 05:07

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests